Last visited website replaces the latest bookmark I created

RESOLVED DUPLICATE of bug 460651

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 460651
9 years ago
9 years ago

People

(Reporter: Ahmet, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

I create a bookmark, and after that I visit some other websites. The URL of the latest website I visited replaces the URL of the latest bookmark I created. Previous bookmarks are safe, but the latest is always getting replaced.

Thank you for your help,

-a

Reproducible: Always

Steps to Reproduce:
1- I create a new bookmark
2- I place it to the bookmark toolbar, either to the root or to any folder (it does not matter)
3- I visit some more websites
4- I close Firefox
5- I launch Firefox
6- The latest bookmark I created keeps the name that I assigned to it, but its URL is the latest website I visited.
Actual Results:  
The latest bookmark I created keeps the name that I assigned to it, but its URL is the latest website I visited.

Expected Results:  
The URL of the bookmark should have been kept as I saved it.
looks like your database is corrupt

please install Sqlite Manager extension, open places.sqlite and execute the query:
PRAGMA integrity_check;

It should return OK

if it returns any error, then this bug is a dupe of bug 460651 (you can close the browser and rename places.sqlite to places.sqlite.bak, this will replace your database and restore bookmarks, but you will LOSE YOUR HISTORY, sadly).
(Reporter)

Comment 2

9 years ago
If I export my bookmarks first, uninstall Firefox, download the latest version, and re-install it, do you think that the problem will be resolved? I mean does uninstalling removes my Firefox DB as well?

Thank you for your help,

-a
no, you don't need to reinstall, nor that will help you... the only way is comment 1, or you could export bookmarks, create a new profile with the profile manager, and import bookmarks (if you use tags i suggest you to use backup and restore with json)
(Reporter)

Comment 4

9 years ago
Yep, I did the "comment 1" and here is the error that SQLlite Manager returns:

"*** in database main ***
On page 1338 at right child: 2nd reference to page 1672"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"
"rowid 14 missing from index moz_places_url_uniqueindex"
"rowid 14 missing from index moz_places_frecencyindex"
"rowid 14 missing from index moz_places_visitcount"
"rowid 14 missing from index moz_places_hostindex"
"rowid 14 missing from index moz_places_faviconindex"


So this should be a duplicate of 460651 as you said, I checked that bug report too they look pretty similar. Anyway, thank you for your help :)

-a
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 460651
try executing REINDEX query... could fix those
(Reporter)

Comment 6

9 years ago
can you give me the full syntax please? Because REINDEX did not return any results / error / message.

Thanks!

-a
REINDEX probably won't return anything, simply rerun PRAGMA integrity_check; after a REINDEX; to check if are there still errors.
(Reporter)

Comment 8

9 years ago
I did REINDEX first, and PRAGMA integrity_check; after that and received the following output:


"*** in database main ***
On page 1338 at right child: 2nd reference to page 1672"
"wrong # of entries in index moz_places_frecencyindex"
"wrong # of entries in index moz_places_visitcount"
"wrong # of entries in index moz_places_hostindex"
"wrong # of entries in index moz_places_faviconindex"
"wrong # of entries in index moz_places_url_uniqueindex"


Do you know how I can resolve this one?

Thanks,

-a
You need to log in before you can comment on or make changes to this bug.