Unread message count not updated until cursor is placed on folder name or new folder is selected

RESOLVED DUPLICATE of bug 492951

Status

RESOLVED DUPLICATE of bug 492951
10 years ago
10 years ago

People

(Reporter: jammerintl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090513 Shiretoko/3.5b5pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090514 Lightning/1.0pre Shredder/3.0b3pre

Beginning with 20090512 daily build of Shredder, the Inbox unread message count is not updated properly as the messages are actually read until you place the cursor over the folder name in the folder pane, or you select a different folder.  The unread message count used to decrease automatically as you proceeded to read the emails.

Reproducible: Always

Steps to Reproduce:
1.Receive a new message in your Inbox.  Folder pane with show the Inbox folder name in bold with a quantity of 1
2.Read the new message.  If you haven't configured TB to automatically mark the message as read, manually mark the message read.
3.Notice the Inbox folder still shows 1 unread message.  Place you cursor on the folder name, and then the Inbox will show as all messages read



This problem is occurring with RSS feed folders as well as the Inbox.  I have tested with "mark messages as read Immediately" and also with the default 5 second delay with the same result.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 492951
You need to log in before you can comment on or make changes to this bug.