Closed Bug 493001 Opened 13 years ago Closed 13 years ago

Dynamically generate weave prefs engine list based on registered engines

Categories

(Cloud Services :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Mardak, Assigned: Mardak)

References

Details

Other data sources should be registering with the weave service with Engines.register, so we can use that to generate a list of engines.

We'll need some way to toggle enabled as well as determine if an engine is disabled.
http://hg.mozilla.org/labs/weave/rev/9558411e9f75

Remove existing hardcoded engine list + prefs and build checkboxes based on registered engines. Engines that give null for enabled (instead of true/false) are considered disabled. Update base Engine enabled get/set to give null and allow setting.
Assignee: nobody → edilee
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: -- → 0.4
Blocks: 493002
Blocks: 493004
Component: Weave → General
Product: Mozilla Labs → Weave
Version: Trunk → unspecified
QA Contact: weave → general
Duplicate of this bug: 488294
You need to log in before you can comment on or make changes to this bug.