If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Folder pane fails to decrement unread count for viewed messages until leaving folder

RESOLVED DUPLICATE of bug 492951

Status

Thunderbird
Folder and Message Lists
--
minor
RESOLVED DUPLICATE of bug 492951
9 years ago
9 years ago

People

(Reporter: Phil Johnson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090514 Shredder/3.0b3pre ID:20090514031430

This problem seems to have started with the 20090513 Shredder build and persists
with the 20090514 build.  When I visit a folder with, say, one unread message,
and then read the message, the folder name remains in bold and the count of
unread messages isn't decremented immediately as it used to be.  The unread
count and bold typeface sometimes are not updated until I leave the folder.

Happens with both IMAP and local folders.  In preferences, I have "Automatically
mark messages as read, Immediately on display."

Reproducible: Always

Steps to Reproduce:
1. In preferences->advanced->reading & display, check "Automatically mark
   messages as read, Immediately on display."
2. Visit folder with one unread message
3. Read the message.  Notice that the folder name is still displayed in bold
   face and the unread count still says "(1)". 
4. Visit a different folder and notice that the previous folder's unread count
   is now brought up to date.
Actual Results:  
Unread status wasn't updated immediately as it is supposed to be.

Expected Results:  
Unread status should be updated as soon as message is read.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 492951
You need to log in before you can comment on or make changes to this bug.