Tables that have colspan="" look weird

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
17 years ago

People

(Reporter: th, Assigned: karnaze)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Mozilla seems to treat the colspan="" attribute as colspan="0" in HTML tables.
As I understand it attr="" equals no attribute with name attr.

This bug makes tables that have the colspan attribute set to "" look weird.

The following sample HTML illustrates this:

<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
  "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">
  <head><title>Mozilla table bug</title></head>
  <body>
    <h1>&lt;td colspan=""&gt;</h1>
    <table>
      <tr>
        <td colspan="">Header 1</td>
        <td colspan="">Header 2</td>
        <td colspan="">Header 3</td>
      </tr>
      <tr>
        <td colspan="">Data 1</td>
        <td colspan="">Data 2</td>
        <td colspan="">Data 3</td>
      </tr>
    </table>
    <h1>&lt;td colspan="1"&gt;</h1>
    <table>
      <tr>
        <td colspan="1">Header 1</td>
	<td colspan="1">Header 2</td>
        <td colspan="1">Header 3</td>
      </tr>
      <tr>
        <td colspan="1">Data 1</td>
        <td colspan="1">Data 2</td>
        <td colspan="1">Data 3</td>
      </tr>
    </table>
  </body>
</html>

Comment 1

19 years ago
This is a html table bug
Assignee: clayton → karnaze
Component: Layout → HTMLTables
QA Contact: petersen → chrisd

Comment 2

19 years ago
Updating summary to make it easier to see what this is on a query results page.
Summary: colspan="" → Tables that have colspan="" look weird

Comment 3

19 years ago
Created attachment 13936 [details]
testcase from the original bugreport

Comment 4

19 years ago
I could reproduce the bug with 2000070208 Win98 and see the correct behaviour
with a debug build from 20000901 Win98. Marking the bug as WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Updated

19 years ago
QA Contact: chrisd → petersen

Comment 5

19 years ago
Works For Me:
OS: Windows 98
Platform: PC
Mozilla Build #: 2000100508

Status: RESOLVED → VERIFIED

Comment 6

17 years ago
Mass removing self from CC list.

Comment 7

17 years ago
Now I feel sumb because I have to add back. Sorry for the spam.
You need to log in before you can comment on or make changes to this bug.