If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Regression as of 3.2: Status no longer changed to NEW from ASSIGNED when assignee is changed.

RESOLVED DUPLICATE of bug 475409

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED DUPLICATE of bug 475409
9 years ago
9 years ago

People

(Reporter: Brad Johnson, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.10) Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10
Build Identifier: 

When you change the assignee of a bug with status ASSIGNED to a new assignee  Bugzilla would change the status back to NEW. This no longer happens in Bugzilla 3.2. This functionality was present in 3.0.

It is important for the status to change to NEW so that the whinemail will be able to whine at the new assignee if they haven't acted on a bug that was re-assigned to them.

Here's the code in 3.0 that was dropped from 3.2:

http://mxr.mozilla.org/bugzilla3.0/source/process_bug.cgi#1178

Reproducible: Always

Comment 1

9 years ago
This is not a regression, but the desired behavior.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 475409
You need to log in before you can comment on or make changes to this bug.