TM: incorrect execution if too little blacklisting happens

RESOLVED DUPLICATE of bug 493657

Status

()

Core
JavaScript Engine
P1
major
RESOLVED DUPLICATE of bug 493657
9 years ago
9 years ago

People

(Reporter: bz, Assigned: gal)

Tracking

(Blocks: 1 bug)

Trunk
mozilla1.9.1
x86
Mac OS X
Points:
---
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

STEPS TO REPRODUCE:

1) Set BL_ATTEMPTS to a number > 2 in jstracer.cpp (I can reproduce the bug with
   it set to 3, but 32 is a good number to try).
2) Recompile your optimized shell.
3) Run it on https://bugzilla.mozilla.org/attachment.cgi?id=377491

EXPECTED RESULTS: Game runs to end and outputs some stats about time taken

ACTUAL RESULTS: foo.js:101: TypeError: myBoard.chainTouchingCountsByChainIdAndStone[i.chainId] is undefined

I wish I had a smaller testcase to offer here...  :(
Flags: blocking1.9.1?
(Assignee)

Comment 1

9 years ago
Wow. Scary. This needs a reduction. Please block on it. Jesse, can you help?
(Assignee)

Updated

9 years ago
Priority: -- → P1
Target Milestone: --- → mozilla1.9.1
(Assignee)

Comment 2

9 years ago
I guess one way to fuzz this would be to build two shells with different BL_ATTEMPTS settings and then compare the outcome.

Updated

9 years ago
Flags: blocking1.9.1? → blocking1.9.1+

Updated

9 years ago
Assignee: general → graydon
(Assignee)

Comment 3

9 years ago
Probably a dup. Verifying that as we speak.
Assignee: graydon → gal
(Assignee)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 493657
You need to log in before you can comment on or make changes to this bug.