Character counter reverts to the older character count after submission

VERIFIED FIXED in 5.0.6

Status

addons.mozilla.org Graveyard
Collections
P3
normal
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: krupa, Assigned: wenzel)

Tracking

unspecified
5.0.6

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

9 years ago
steps to reproduce:
1.Click "edit" for one of your collections
2.In the collection name field,enter 52 character-long name
3.Notice the character counter(52/50)
4.Edit the collection name to be 50 character-long name
5.Notice the character counter(50/50)
6.Click update collection.
7.Notice the character counter.

expected results:
Character counter says (50/50)

actual result:
Character counter says (52/50)

screencast:  http://screencast.com/t/0taGlpYo
(Reporter)

Comment 1

9 years ago
Created attachment 377520 [details]
character counter
(Reporter)

Comment 2

9 years ago
The same behavior can be reproduced for the character counter for collection description as well.
(Assignee)

Comment 3

9 years ago
Is this still showing up for you? While I watched your screencast (in other words I do believe you!), I cannot reproduce it. It may have something to do with the length of collection names having been unrestricted before.
OS: Mac OS X → AIX
Hardware: x86 → All
(Reporter)

Comment 4

9 years ago
http://screencast.com/t/uhBPT5vrua


In this screencast the character counter jumps to the previous count which was 45.
(Reporter)

Comment 5

9 years ago
Some more details:

After submission,the data in the edit page fields are not updated to the new value.

This screencast makes it clear.

http://screencast.com/t/E33ZgP9Atyt

Fred,If you can reproduce the behavior,I can update the bug.
Priority: -- → P3
(Assignee)

Comment 6

9 years ago
Ah, this seems to be a caching issue :-/ I will need to disable query caching
on the collections edit page.
(Assignee)

Comment 7

9 years ago
Created attachment 378602 [details] [diff] [review]
Disabling query caching on edit page

This should do the trick. It does not cause errors here, but if it actually and consistently solves the problem, we'll see.

However, I am pretty confident it will :)
Assignee: nobody → fwenzel
Status: NEW → ASSIGNED
Attachment #378602 - Flags: review?(clouserw)
(Assignee)

Updated

9 years ago
OS: AIX → All
/me is not excited about completely disabling caching even if it is just one function in the controller.  Can you narrow it down to just one model at least?
(Assignee)

Comment 9

9 years ago
Certainly. Just switching it off for the collections model should work.
(Assignee)

Comment 10

9 years ago
Created attachment 378864 [details] [diff] [review]
Patch, rev. 2
Attachment #378602 - Attachment is obsolete: true
Attachment #378864 - Flags: review?(clouserw)
Attachment #378602 - Flags: review?(clouserw)
Attachment #378864 - Flags: review?(clouserw) → review+
(Assignee)

Comment 11

9 years ago
r26026. That fixes this, I hope.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: push-needed
Resolution: --- → FIXED
(Reporter)

Comment 12

9 years ago
works now.verified.
Status: RESOLVED → VERIFIED
removing "push-needed" from 105 AMO 5.0.6 bugs; filter on "I hate stephend!"
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.