If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Geolocation doesn't save the access_token cookie AFAICT

RESOLVED WORKSFORME

Status

()

Core
Geolocation
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Natch, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
STR:

1) Load http://www.geocities.com/highmind63/geo.html
2) Click on the larry and allow the website to obtain geo information
3) Close the tab
4) Search about:config access_token.

Expected Results:
There should be a single pref with a value containing the website loaded in step 1.

Actual Results:
No prefs at all.

I'm not 100% sure what the bug is here, or if there really is a bug at all, but to my knowledge there should be a "cookie pref" when a site accesses the geo information. Cc'ing dougt, he can hopefully weigh in here.

Observed on:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b5pre) Gecko/20090512 Shiretoko/3.5b5pre

and

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090514 Minefield/3.6a1pre
Flags: blocking1.9.1?
(Reporter)

Comment 1

9 years ago
Created attachment 377607 [details]
testcase

Adding the testcase here, just in case it gets lost somewhere along the way.

Comment 2

9 years ago
access_token is only saved after you press the accept button, and a network request is return containing the access token.

when you click on the "allow the website to obtain geo", that sets permission for "geo" for that given page.

Does this help?
(Reporter)

Comment 3

9 years ago
(In reply to comment #2)
No. I get the alerts confirming that the location is returned from the server, but I never get a cookie pref. I tried only clicking "Allow", then I tried clicking "Allow" and "remember this choice".

Interestingly, though, I get the access_token when I try this at work, is there a difference whether I'm on WIFI or just regular LAN?

Comment 4

9 years ago
the server may not send back a access token when we don't send wifi data.

Just to be clear -- the access_token is set when we send wifi data, right?
(Reporter)

Comment 5

9 years ago
Just to clarify:

At home: I connect to my network (and to the net) via wifi. No access_token is set/received.

At work: I connect to my network (and to the net) via a standard ethernet cable. Here I do get an access_token.

I'm not sure if wifi data is being sent in either location, should it send that data if there is _any_ wifi connection present, or only if the wifi router has some feature of some sort?

Is there any way I can debug this perhaps? Would the LOG function help you out here?

Comment 6

9 years ago
natch, yeah, if you don't mind.  Please uncomment out that LOG function, and send me the javascript console output.  Keep in mind, that your approximate location is included in this output, so you might not want to post it here.
(Reporter)

Comment 7

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090515 Minefield/3.6a1pre

Sorry for the headache, this was a local build problem apparently, with an official nightly I can't reproduce any of this. What the reason is exactly is beyond me, and I didn't get any spew in the error console even with the LOG function uncommented :/
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: blocking1.9.1?
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.