Set default downloads pivot before loading saved downloads

RESOLVED FIXED

Status

--
trivial
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: ishermandom+bugs, Assigned: ishermandom+bugs)

Tracking

Trunk
All
Mac OS X

Details

Attachments

(1 attachment, 1 obsolete attachment)

1018 bytes, patch
stuart.morgan+bugzilla
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

10 years ago
Created attachment 377617 [details] [diff] [review]
Fix

We should set the default pivot (-1) before loading saved downloads since that can update the pivot to something more useful.
Attachment #377617 - Flags: superreview?(stuart.morgan+bugzilla)
(Assignee)

Comment 1

10 years ago
Created attachment 377619 [details] [diff] [review]
Fix w/whitespace

Someday I will learn to post the right version of the patch the first time...
Attachment #377617 - Attachment is obsolete: true
Attachment #377619 - Flags: superreview?(stuart.morgan+bugzilla)
Attachment #377617 - Flags: superreview?(stuart.morgan+bugzilla)

Comment 2

10 years ago
Comment on attachment 377619 [details] [diff] [review]
Fix w/whitespace

sr=smorgan
Attachment #377619 - Flags: superreview?(stuart.morgan+bugzilla) → superreview+
Checked in.  I wasn't sure what sorts of changes (regressions) to look for before landing, so I only made sure it built.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.