Closed Bug 493199 Opened 11 years ago Closed 11 years ago

Need API for addon to hook into a Sanitizer

Categories

(Firefox :: General, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: howdy555, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

The sanitizer is designed to clean all private data when needed. Unfortunately it works only for main application and not for addons. It is possible to hook into it but it is unofficial way of doing it. What I would like to propose is to allow addon programmers to respond to user selecting Tools/Clean private data in order to remove log files and other potentially sensitive data.

Reproducible: Always

Steps to Reproduce:
1. Press CTRL+SHIFT+DEL
2. Tick everything and allow Firefox to clean private data
Actual Results:  
Firefox private data is cleaned. Private data stored by addons is NOT. There is no official way for an addon author to respond to "sanitize" event.

Expected Results:  
Both Firefox and addon private data is cleaned. It is impossible to tell which sites were visited and what passwords were entered before cleaning.

This proposal is due to the discussion with Adblock plus author - see 

http://adblockplus.org/forum/viewtopic.php?t=3939

Note! This is NOT a problem with Adblock. Adblock should only be considered an example of an addon that could benefit from such an API.
Moving to Firefox / General for lack of a better component. Note that fixing this bug would involve moving the sanitizer into toolkit. As it stands now, there are separate copies of the sanitizer code in Firefox, Fennec, Prism and probably a few other applications as well. "Hacking" the code in each of those from an extension is going to be disastrous (which doesn't keep some extensions from trying).
Blocks: abp
Component: Security → General
QA Contact: firefox → general
An extension can listen for the "browser:purge-session-history" notification - I think that bug is WORKSFORME then.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.