attempts to copy sent html messages to the wrong sent mail folder

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
--
major
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: Seb Hunt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10
Build Identifier: version 2.0.0.21 (20090302)

In preferences I have set my sent mail folder to be a folder on the imap server (different from the default Sent folder). I usually send plain text messages and this works fine. But when I send an html message TB tries to copy it to the default Sent folder (this fails in my case since the default Sent folder does not exist on the server and TB is unable to create it - which is why I have chosen an alternate folder in the first place).

Reproducible: Always

Steps to Reproduce:
1. Configure TB to use an alternate sent mail folder on the imap server.
2. Compose and send an html message.
Actual Results:  
TB attempts to copy the sent html message to the default Sent folder (this fails in my case, though that is not the issue).

Expected Results:  
Message is copied to the the designated alternate sent mail folder.

This only happens when sending html messages. Everything works as expected for plain text messages.
> Steps to Reproduce:
> 1. Configure TB to use an alternate sent mail folder on the imap server.
> 2. Compose and send an html message.
> Actual Results:  
> TB attempts to copy the sent html message to the default Sent folder (this
> fails in my case, though that is not the issue).

(Check Q1 to Q4 before restart of Tb)
(Q1) Icon for folder of the "alternate sent mail folder" at step 1 is changed
     to "trash can icon" from "iocn for oridinal folder" after step 1?
     When the "alternate sent mail folder" is clicked after change at step 1,
     which column is showed? "Sender"(or From) columns? Or "Recipient" column?
(Q2) No problem always if you compose&send text mail at step 2?
(Q3) Do you enable auto-save? (AFAIR, default=On, each 5 min.)
(Q4) Folder for "draft save"(set in "Copies&Folders") exists?
     What folder is set for "draft save"?
     Check mail.identity.idN.draft_folder via "Config Editor"

(Check Q5 after restart of Tb)
(Q5) Does your problem occur even after restart of Tb?
(Reporter)

Comment 2

9 years ago
In trying to answer these questions I managed to screw up my profile (or maybe it was already screwed up). Anyway, I've started afresh and now I can no longer reproduce the problem. I was previously tunneling to the imap server and now I'm not, maybe that has some relevance. Anyway, better retire this bug I suppose - sorry. Thanks for looking into it.
Closing as INVALID.
Re-open please, if you'll find that your problem was caused by Tb's flaw in code, with attaching evidence data such as log, trace, corrupted file by *Tb*.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.