Seeking forward or backwards in videos with audio no longer works

RESOLVED FIXED

Status

()

Core
Audio/Video
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: cajbir, Assigned: cajbir)

Tracking

({fixed1.9.1})

Trunk
fixed1.9.1
Points:
---
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
This is a regression introduced by bug 466699 landing. When playing a video, then seeking anywhere in that video, playback gets confused. It sometimes stops the video, but continues the audio, sometimes stops both.

This appears to be due to the hardware audio clock time being out of sync from the video time after a seek. It was not picked up by tests due to the tinderboxes not having audio hardware - so no hardware audio clock to sync against.
Flags: blocking1.9.1?
Assignee: nobody → chris.double
Flags: blocking1.9.1? → blocking1.9.1+
(Assignee)

Comment 1

9 years ago
Created attachment 377990 [details] [diff] [review]
fix

Closes the audio stream when seeking. This resets the hardware time when the stream is re-opened during resumption of decoding.
Attachment #377990 - Flags: superreview?(roc)
Attachment #377990 - Flags: review?(roc)
Attachment #377990 - Attachment is patch: true
Attachment #377990 - Attachment mime type: application/octet-stream → text/plain
Attachment #377990 - Flags: superreview?(roc)
Attachment #377990 - Flags: superreview+
Attachment #377990 - Flags: review?(roc)
Attachment #377990 - Flags: review+
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.