information is selected in a text box after I've already typed in it causing my input to be overwritten

RESOLVED INVALID

Status

()

RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: meghan_allen, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10

I have been using Firefox for a long time (at least since version 1.0) and have only noticed this problem recently.  Updates are automatically installed, so I can't be sure when it started happening but I suspect it started with 3.0.10.
 
When I'm inputing information on forms, I tab to get to the next field.  Everything always works as expected for the first text input field.  Then, I tab to the second field and start typing.  After I've typed a few characters, everything in the field that I am currently typing in becomes selected (I assume it's getting the focus).  Obviously, if I keep typing, the selected text gets overwritten with the rest of the text that I type. 

At first I didn't notice what was happening and it was causing me to type my password wrong over and over.  

Example: (if my password was 123456) 
- I'd first enter my username and then I'd tab to the password field
- I'd start typing my password 
- after I'd typed 123 - the 123 would get selected
- since I didn't notice I'd keep typing and the 456 would overwrite the 123.  
- I'd automatically press enter after I'd typed my password 
- I wouldn't get logged in because only half of my password was present.

A workaround is to wait a bit after I've tabbed to the second field before I start entering information.  This is frustrating though, because I have always been able to enter my information quickly in Firefox and now I have to remember to tab and then wait a bit.  It seems to be fine when I wait for the cursor to flash at least twice in the second text field before I start typing.

As far as I can tell, it doesn't matter if the page is loading or if it's already fully loaded.

Reproducible: Always

Steps to Reproduce:
1. Go to a page with more than one text field
2. Enter some information in the first text field
3. tab to the second text field and immediately start typing
Actual Results:  
after a few characters (3-5 usually, for me) are typed in the second text input field, the inputted text becomes selected.  If you don't notice and just keep typing, the selected text becomes overwritten with the new text that you enter.

Expected Results:  
First, I don't think that a text input field should receive the focus if the user is already typing in that field.

Even if a text input field does receive focus when it's already being used, I would expect that it wouldn't affect the users actions (ie, wouldn't select the text) 

I read both lists (Top 100 and Hot in the last 2 weeks) and searched for this bug so I hope it's not a duplicate.  I'll be happy to provide more info it it would be helpful.
Do you see the same in safe-mode? http://support.mozilla.com/en-US/kb/Safe+Mode
Version: unspecified → 3.0 Branch
(Reporter)

Comment 2

10 years ago
No, I don't get the same behaviour in safe-mode.  In safe-mode it works as expected.  Is this an indication that it's probably due to one of my add-ons?  (Thanks for the quick response!)
(In reply to comment #2)
> No, I don't get the same behaviour in safe-mode.  In safe-mode it works as
> expected.  Is this an indication that it's probably due to one of my add-ons? 
> (Thanks for the quick response!)

Yes, please locate the guilty extension and disable or uninstall it. Maybe the author has an update?
Resolving Invalid, because this is not caused by Firefox's code.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 4

9 years ago
I am able to reproduce this issue for quite a long time on some sites I visit. 

For example, the Internet gateway in the Mozilla Summit page is causing this issue when I type something in the Group Access access-code. 

https://p1297.superclick.com/std/fairmontv5.2/wifiindex.php?group=21&roomid=977&lang=en&deflang=en&preview=
You need to log in before you can comment on or make changes to this bug.