Last Comment Bug 493593 - when no account is set up yet - uncaught exception calling nsIMsgSendLater.hasUnsentMessages
: when no account is set up yet - uncaught exception calling nsIMsgSendLater.ha...
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Composition (show other bugs)
: Trunk
: All All
: -- minor (vote)
: Thunderbird 14.0
Assigned To: Magnus Melin
:
Mentors:
: 536882 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 11:47 PDT by Martin Schröder [:mschroeder]
Modified: 2012-04-19 10:56 PDT (History)
6 users (show)
mkmelin+mozilla: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
proposed fix (1.44 KB, patch)
2012-03-29 12:05 PDT, Magnus Melin
standard8: review+
Details | Diff | Splinter Review

Description Martin Schröder [:mschroeder] 2009-05-18 11:47:05 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090518 Lightning/1.0pre Shredder/3.0b3pre

Start-up of Thunderbird without any account/identity created results in:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgSendLater.hasUnsentMessages]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/mail-offline.js :: anonymous :: line 84"  data: no]
Comment 1 Magnus Melin 2009-05-18 12:21:28 PDT
I was just about to file this. (Linux too!)
Comment 2 Martin Schröder [:mschroeder] 2009-05-31 02:30:44 PDT
Seems to be fixed after http://hg.mozilla.org/comm-central/rev/f2ad961aefcb#l3.77 has been checked in. Magnus, do you agree?
Comment 3 Magnus Melin 2009-05-31 03:38:17 PDT
Nope, still there using 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1pre) Gecko/20090530 Shredder/3.0b3pre

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgSendLater.hasUnsentMessages]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/mail-offline.js :: anonymous :: line 84"  data: no]
Comment 4 Ginn Chen 2009-12-07 22:41:23 PST
I got this exception when I try to go switch offline to online with one of my thunderbird profile.
I have to restart thunderbird to get back online.

With this profile, I even removed all my accounts, it still does not work.
Comment 5 Michael Steiner 2009-12-29 11:23:15 PST
*** Bug 536882 has been marked as a duplicate of this bug. ***
Comment 6 Michael Steiner 2010-01-15 18:52:19 PST
Interesting observations i just made: the de-offlining via Menu or offline button still doesn't work with TB3.0.1b. However, there is a way to get into online mode again: If you go to Tools->add on and try to find updates, you get the error messsage that TB is offline and it offers you the button to ``Go Online'' and, surprise, surprise, via this button you do in fact get back into online mode!!
Comment 7 Florian Quèze [:florian] [:flo] 2012-03-26 06:49:57 PDT
In the terminal of a debug build, I see:

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgAccountManager.defaultAccount]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/msgMail3PaneWindow.js :: loadStartFolder :: line 778"  data: no]Exception in LoadStartFolder caused by no default account.  We know about this
WARNING: can't determine folder's server type: file /Users/florian/buildhg/comm-central/mailnews/base/util/nsMsgDBFolder.cpp, line 3182
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file /Users/florian/buildhg/comm-central/mailnews/compose/src/nsMsgCopy.cpp, line 465
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file /Users/florian/buildhg/comm-central/mailnews/compose/src/nsMsgSendLater.cpp, line 744
JavaScript error: , line 0: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgSendLater.hasUnsentMessages]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/mail-offline.js :: <TOP_LEVEL> :: line 81"  data: no]
Comment 8 Florian Quèze [:florian] [:flo] 2012-03-26 07:43:48 PDT
(In reply to Florian Quèze from comment #7)
> In the terminal of a debug build, I see:
> 
> [Exception... "Component returned failure code: 0x80004005
> (NS_ERROR_FAILURE) [nsIMsgAccountManager.defaultAccount]"  nsresult:
> "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
> chrome://messenger/content/msgMail3PaneWindow.js :: loadStartFolder :: line
> 778"  data: no]Exception in LoadStartFolder caused by no default account. 
> We know about this

This part of the noise I saw in my terminal is unrelated to calling nsIMsgSendLater.hasUnsentMessages, I filed bug 739222 on it.
Comment 9 Magnus Melin 2012-03-29 12:05:34 PDT
Created attachment 610635 [details] [diff] [review]
proposed fix
Comment 10 Magnus Melin 2012-04-19 10:56:08 PDT
http://hg.mozilla.org/comm-central/rev/f40249b16796 -> FIXED

Note You need to log in before you can comment on or make changes to this bug.