Open Bug 493692 Opened 11 years ago Updated 4 years ago

[test disabled] test_preload_suspend.html fails a lot

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set
normal

Tracking

()

People

(Reporter: roc, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [test disabled][rr])

Attachments

(1 file)

I've disabled it for now. Sometimes it seems 'load' events are failing to be fired, especially on Linux.
Blocks: 438871
Whiteboard: [orange]
I disabled this on 1.9.1 due to random failure.
Assignee: roc → nobody
Test renamed/refactored to test_preload_suspend.html, still disabled.
Summary: test_autobuffer2.html fails a lot → [test disabled] test_preload_suspend.html fails a lot
Whiteboard: [orange] → [test disabled][orange]
Whiteboard: [test disabled][orange] → [test disabled]
I have this recorded in rr.
Whiteboard: [test disabled] → [test disabled][rr]
Unfortunately the test has "function is() {}" which makes debugging somewhat harder...
Attached patch fixSplinter Review
Assignee: nobody → roc
Attachment #8388290 - Flags: review?(cpearce)
Comment on attachment 8388290 [details] [diff] [review]
fix

Review of attachment 8388290 [details] [diff] [review]:
-----------------------------------------------------------------

You need to delete the "function is() {}" on line 27 too, otherwise no tests run.
Attachment #8388290 - Flags: review?(cpearce) → review+
Component: Audio/Video → Audio/Video: Playback
Assignee: roc → nobody
You need to log in before you can comment on or make changes to this bug.