Create localizer LDAP/SVN account for Amitakhya Phukan

RESOLVED FIXED

Status

mozilla.org
Repository Account Requests
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: pascalc, Assigned: fox2mike)

Tracking

Details

(Reporter)

Description

9 years ago
Please create SVN account for:

Name: Amitakhya Phukan
Locale: as
email: aphukan.mozilla@gmail.com

This user needs to be added to our localizers group for SVN to commit via HTTPS with LDAP.

I believe his LDAP account was already created when his CVS/HG account was created in bug #448352 (committer's agreement sent too) but Amitakhya does not have a password for this account. If no LDAP account was created for him, please create one, if he has an LDAP account, please reset the password and send it to him.

Thanks 

Thanks
(Reporter)

Updated

9 years ago
Assignee: marcia → shyam
I see nothing in bug 448352 about a confirmed form. Checking the spreadsheet, I don't see his name on the list.

Erica, do you have a form on file for Amitakhya?
Assignee: shyam → marcia

Comment 2

9 years ago
I think the bug 448352 is resolved now. So this bug should proceed further...

Comment 3

9 years ago
I do not have a form for Amitakhya.

Comment 4

9 years ago
From bug 448352,

--- Comment #4 from Axel Hecht [:Pike] <l10n@mozilla.com>  2008-08-07 04:06:23 PDT ---
adjusting subject.

Marcia and I got a email with the scanned form, Marcia, this is ready to go
over to IT AFAICT.

===========================================================

I had already sent the form. Is there anything that I need to do more ?

Comment 5

9 years ago
I have received the form via email and forwarded it to Erica, CC:ing Axel and Amit.

Comment 6

9 years ago
I have received Amitakhya's Committer's Agreement.
This one can go over to server ops.
Assignee: marcia → server-ops

Updated

9 years ago
Assignee: server-ops → shyam
(Assignee)

Comment 8

9 years ago
LDAP password has been reset and emailed to Amitakhya. SVN access has been granted for /projects/mozilla.com/trunk/as
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 9

9 years ago
Hello,

Thanks a lot for your help. But I ran into some problems.

============================================================

$ svn co svn+ssh://'aphukan.mozilla@gmail.com'@svn.mozilla.org/svn/projects/mozilla.com/trunk/as
The authenticity of host 'svn.mozilla.org (63.245.208.183)' can't be established.
RSA key fingerprint is fa:e8:5a:cc:de:02:e0:c7:6e:ff:14:92:90:b9:12:be.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'svn.mozilla.org,63.245.208.183' (RSA) to the list of known hosts.
Enter passphrase for key '/home/amit/.ssh/id_dsa':
svn: URL 'svn+ssh://aphukan.mozilla@gmail.com@svn.mozilla.org/svn/projects/mozilla.com/trunk/as' doesn't exist

===========================================================

Anything I should do from my side to resolve this error ?
(Assignee)

Comment 10

9 years ago
(In reply to comment #9)

> Anything I should do from my side to resolve this error ?

According to Pascal, 

Please create SVN account for:

Name: Amitakhya Phukan
Locale: as

If that locale didn't exist before or hasn't been worked upon at all, you might have to end up creating it?

Comment 11

9 years ago
The locale does exist and I have been working on it.

http://hg.mozilla.org/releases/l10n-mozilla-1.9.1/as

Comment 12

9 years ago
It exists here as well: http://svn.mozilla.org/projects/mozilla.com/trunk/as/

I wonder why Amitakhya couldn't get it...

Comment 13

9 years ago
Amitakhya,

I think you forgot to put ":" after the svn server name.

svn co svn+ssh://'aphukan.mozilla@gmail.com'@svn.mozilla.org:/svn/projects/mozilla.com/trunk/as

check this...

Comment 14

9 years ago
That does not help either :

----------------------------------------------------
svn co svn+ssh://'aphukan.mozilla@gmail.com'@svn.mozilla.org:/svn/projects/mozilla.com/trunk/as
ssh: Could not resolve hostname svn.mozilla.org:: Name or service not known
svn: Network connection closed unexpectedly
----------------------------------------------------

Comment 15

9 years ago
Looks like the single quotes are causing some issue here.

Try following:

svn co
svn+ssh://aphukan.mozilla@gmail.com@svn.mozilla.org:/svn/projects/mozilla.com/trunk/as

Comment 16

9 years ago
Nope, that doesn't help either.

----------------------------------------
$ svn co svn+ssh://aphukan.mozilla@gmail.com@svn.mozilla.org:/svn/projects/mozilla.com/trunk/as
ssh: Could not resolve hostname svn.mozilla.org:: Name or service not known
svn: Network connection closed unexpectedly
---------------------------------------

Second attempt after removing the ":"
-----------------------------------------
$ svn co svn+ssh://aphukan.mozilla@gmail.com@svn.mozilla.org/svn/projects/mozilla.com/trunk/as
svn: URL 'svn+ssh://aphukan.mozilla@gmail.com@svn.mozilla.org/svn/projects/mozilla.com/trunk/as' doesn't exist
-----------------------------------------

Permission/username issue ??
(Assignee)

Comment 17

9 years ago
(In reply to comment #16)

> Permission/username issue ??

Nope. Wrong URL. See https://wiki.mozilla.org/SVN

It should be :

svn co
svn+ssh://'aphukan.mozilla@gmail.com'@svn.mozilla.org/projects/mozilla.com/trunk/as

Comment 18

9 years ago
Hi,

Thanks a lot. I could check out now.

Comment 19

9 years ago
Hi,

I was working on bug 528971. I could not make a svn commit. Is it because I was supposed to make a commit in branches, I was not allowed ?

Here is the output of svn commit:

Password for 'aphukan.mozilla@gmail.com': 
svn: Commit failed (details follow):
svn: MKACTIVITY of '/!svn/act/5f8b019e-f029-41f0-ba8f-f0abd8f048c1': authorization failed: Could not authenticate to server: rejected Basic challenge (https://svn.mozilla.org)

Please do let me know what happened here.

Thanks.

Comment 20

9 years ago
Sorry to comment on the same bug. Should I have opened a new one ?

Comment 21

9 years ago
open a new bug and provide a reference of this bug in the new bug.

Updated

8 years ago
Component: Account Request: SVN → Repository Account Requests
QA Contact: svn-acct-req → repo-acct-req
You need to log in before you can comment on or make changes to this bug.