Closed Bug 493738 Opened 11 years ago Closed 11 years ago

The CSS rule for sanitize.xul is moved from skin/preferences/preferences.css to skin/sanitizeDialog.css

Categories

(Firefox :: Theme, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 3.6a1

People

(Reporter: spitfire.kuden, Assigned: ehsan)

References

Details

Attachments

(1 file)

User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090519 Minefield/3.6a1pre {Build ID: 20090519050407}

sanitize.xul uses skin/sanitizeDialog.css now.
However, sanitize.xul also still uses skin/preferences/preferences.css. 
http://hg.mozilla.org/mozilla-central/annotate/38d50cc03a72/browser/base/content/sanitize.xul#l45

It is necessary to move the CSS rule that sanitize.xul uses from skin/preferences/preferences.css to skin/sanitizeDialog.css, and not to use skin/preferences/preferences.css.
Component: Private Browsing → Theme
QA Contact: private.browsing → theme
To be clear, the sanitize.xul referred to in comment 0 is browser/base/content/sanitize.xul (the CRH dialog), not browser/components/preferences/sanitize.xul (a separate dialog involved with the privacy pref pane).

On Pinstripe the CRH dialog does use the .prefWindow-dlgbuttons and description selectors from browser/preferences/preferences.css.  .prefWindow-dlgbuttons sets all the margins of the dialog's OK/cancel buttons.  (browser/sanitizeDialog.css overrides the buttons' -moz-margin-end.)  description applies to the warning text when the duration dropdown is set to clear everything.

So this bug could be invalid, but maybe a better solution would be to remove Pinstripe's small dependency on browser/preferences/preferences.css.  CRH doesn't really look or act like a prefwindow anyway.
(In reply to comment #1)
> So this bug could be invalid, but maybe a better solution would be to remove
> Pinstripe's small dependency on browser/preferences/preferences.css.  CRH
> doesn't really look or act like a prefwindow anyway.

I do not know Pinstripe in detail...

Pinstripe selects 1 or 2:
1. Some rules are copied from browser/preferences/preferences.css to browser/sanitizeDialog.css. 
2. Some rules are moved from browser/preferences/preferences.css to global/preferences.css.

Winstripe and Gnomestripe set .prefWindow-dlgbuttons on global/preferences.css. 
global/preferences.css is a style to general prefwindow, and browser/preferences/preferences.css is a style to Options (Prefwindow V) and the child prefwindow.
Bug 504300 was fixed. 
The problem of comment #3 on Pinstripe (Firelight) was solved. 

Basically, when this line is deleted, this bug will be fixed.
http://hg.mozilla.org/mozilla-central/annotate/38bc9063e689/browser/base/content/sanitize.xul#l45

There is an anxiety of causing regression by the development in the future if this bug is not fixed. 
Because a needless element of browser/sanitizeDialog.css remains.
Kuden, would you like to create a patch for this? I could review it.
(In reply to comment #4)
> Kuden, would you like to create a patch for this? I could review it.

I have not experienced the programming. 
And, I have not experienced CUI. 
Therefore, it is difficult for me to make the patch...
Attached patch No-brainer :-)Splinter Review
Assignee: nobody → ehsan.akhgari
Status: NEW → ASSIGNED
Attachment #389889 - Flags: review?(dao)
Attachment #389889 - Flags: review?(dao) → review+
http://hg.mozilla.org/mozilla-central/rev/02f8bf10f441
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.6a1
Verified fixed by code-checkin.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.