add tool for running abc tests in the flash player

VERIFIED FIXED

Status

Tamarin
Tools
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: Dan Schaffer, Unassigned)

Tracking

unspecified
x86
Mac OS X
Bug Flags:
flashplayer-triage +

Details

Attachments

(1 attachment)

24.05 KB, patch
Tommy Reilly
: review+
Brent Baker
: review+
Details | Diff | Splinter Review
(Reporter)

Description

9 years ago
create a tool for running abc tests as swfs in the flash player.  tool will capture results from player and send back to stdout so can be used with runtests.py.

requirements:
- input is any abc file, generally acceptance test and performance test files
- all print statements are displayed in the swf in a textfield and returned from the script to stdout
- supports standalone player and all browsers
Flags: flashplayer-triage+
(Reporter)

Comment 1

9 years ago
Created attachment 378419 [details] [diff] [review]
patch

the patch contains tools to convert abc to swf and a runner script to invoke the player/browser calling the swf and capturing output to sdout.  The flashrunner.sh script can be set to AVM environment variable and plugged into runtests.py.

test/util/flashrunnner/readme.txt has setup instructions.
Attachment #378419 - Flags: review?(treilly)
(Reporter)

Updated

9 years ago
Attachment #378419 - Flags: review?(brbaker)

Updated

9 years ago
Attachment #378419 - Flags: review?(treilly) → review+

Comment 2

9 years ago
Comment on attachment 378419 [details] [diff] [review]
patch

Should document a couple of more things in the readme:

+ testcases must use print(), trace() is not supported
+ should not use threads with runtests
+ how do people get the playerglobal.abc?
+ before compiling the swf should make sure that PLAYERGLOBALABC is defined
+
Attachment #378419 - Flags: review?(brbaker) → review+

Comment 3

9 years ago
+ make sure to add an entry in .hgignore for test/util/flashrunner/working/
(Reporter)

Comment 4

9 years ago
pushed into tr 1945:b2445d9225c7
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Duplicate of this bug: 491495

Comment 6

9 years ago
Resolved fixed engineering / work item that has been pushed.  Setting status to verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.