Disabled products show up in the pick list for existing bugs

RESOLVED FIXED in Bugzilla 3.4

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Greg Hendricks, Assigned: Frédéric Buclin)

Tracking

({regression})

Bugzilla 3.4
regression
Bug Flags:
approval +
approval3.4 +
blocking3.4 +

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
This will be fixed going forward in bug 493090, but for 3.4 we need to have a workaround. Overriding Product::get_legal_values should do it.
Flags: blocking3.4?

Updated

9 years ago
Flags: blocking3.4? → blocking3.4+
Whiteboard: [3.4 only--bug 493090 will fix on tip]
Target Milestone: --- → Bugzilla 3.4

Updated

9 years ago
Severity: enhancement → normal
(Assignee)

Comment 1

9 years ago
Created attachment 378607 [details] [diff] [review]
patch, v1

Overriding Product::get_legal_values is not the right way to go as you still want to list the closed product if the bug is already in this product. Closed products are still legal; it's the job of the template to ignore them if their are unwanted at some places.
Assignee: general → LpSolit
Status: NEW → ASSIGNED
Attachment #378607 - Flags: review?(mkanat)
(Assignee)

Comment 2

9 years ago
The patch must land on tip too. It will be removed once bug 493090 is ready.
Component: Bugzilla-General → Creating/Changing Bugs
Whiteboard: [3.4 only--bug 493090 will fix on tip]
(Assignee)

Updated

9 years ago
Keywords: regression
(Reporter)

Comment 3

9 years ago
(In reply to comment #2)
> The patch must land on tip too. It will be removed once bug 493090 is ready.

Ok, actually the fix for tip will be part of bug 456743 since product will be treated the same as any other field for the purposes of editing.

Comment 4

9 years ago
Comment on attachment 378607 [details] [diff] [review]
patch, v1

That's a good hack for 3.4.
Attachment #378607 - Flags: review?(mkanat) → review+

Comment 5

9 years ago
Let's check this in on tip too, but ghendricks--make sure to remove it in your tip patch.
Flags: approval3.4+
Flags: approval+
(Assignee)

Comment 6

9 years ago
tip:

Checking in template/en/default/bug/field.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/field.html.tmpl,v  <--  field.html.tmpl
new revision: 1.26; previous revision: 1.25
done

3.3.4:

Checking in template/en/default/bug/field.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/field.html.tmpl,v  <--  field.html.tmpl
new revision: 1.24.2.2; previous revision: 1.24.2.1
done
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.