border lines of table cells not rendering

VERIFIED DUPLICATE of bug 45055

Status

()

P3
normal
VERIFIED DUPLICATE of bug 45055
18 years ago
18 years ago

People

(Reporter: Michael_B_Allen, Assigned: pierre)

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.51 [en] (WinNT; U)
BuildID:    2000080923

Style directives like

.t
{
    BORDER-BOTTOM: 1px solid;
    BORDER-LEFT: 0px solid;
    BORDER-RIGHT: 1px solid;
    BORDER-TOP: 0px solid;

Do not work. Style available here

http://users.erols.com/mballen/style.css

Reproducible: Always
Steps to Reproduce:
1. visit http://users.erols.com/mballen/style.html
2.
3.

Actual Results:  				Table cell borders do not 
appear at all. In ie this is the technique one would use to achive borders of 1 
pxl width. Should be equivelent of the effect available.			

Expected Results:  				Display 1 pxl wide borders 
around cells like this

http://users.erols.com/mballen/style.gif			

					I realize this is kind of a hack way to 
get borders around table cells but theoretically it should work.

Comment 1

18 years ago
This may be be a duplicate of bug 43859.  Can someone take a look at it?

Comment 2

18 years ago

*** This bug has been marked as a duplicate of 45055 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
This is NOT a dupe of 45055.

The table in the mentioned page has border=0, which causes the border not to be
rendered.

I don't know, if CSS for a TD should override the border=0 in TABLE.
If so, this bug should be reopened. Otherwise it's invalid.
Not invalid, but a dupe of bug 25228.

Comment 5

18 years ago
verified dup of #25228. Table border=0 but with CSS borders display no borders.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.