Cannot scroll choices in a <select> tag using size attribute

RESOLVED DUPLICATE of bug 472426

Status

defect
RESOLVED DUPLICATE of bug 472426
10 years ago
10 years ago

People

(Reporter: bcombee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
The test page sets up a <select> element with lots of <option> choices.  It uses the size attribute to make it a listbox instead of a combobox.  Since Fennec doesn't display the scrollbars or support dragging controls, there's no way to select items in the list that are off screen.

The list probably needs the same kind of scrolling logic that's applied to iframes.
Posted patch patch v1Splinter Review
Patch makes <select> and other scrollable elements by pannig action. I tested this patch on the page: https://bugzilla.mozilla.org/query.cgi?format=advanced

There are some notes:
 1. To prevent unexpectedly blocking of normal panning, elements are
    scrolled only when the browser zoomed.
 2. To prevent memory-leak, I added "BrowserLocationChange" event dispatched
    by <browser>s.
 3. Dragging on the thumb in scrollbars still work as panning, not dragging
    of the thumb.
Attachment #383081 - Flags: review?(combee)

Updated

10 years ago
Attachment #383081 - Flags: review?(combee) → review?(mark.finkle)
On iPhone, combobox-style <select> is rendered just same as a dropdown-style <select> on the page, but, tapping on the element shows the custom UI for combobox-style <select>. I think we should implement special UIs for HTML form controls like it. However, even if we need more accessible UIs for form controls, we also need scroll-ability for general elements. (And this patch possibly help those cases.)
Attachment #383081 - Flags: review?(mark.finkle)
Comment on attachment 383081 [details] [diff] [review]
patch v1

We have 3 bugs with very similar patches. Bug 458741 is also about scrolling elements in the page. Bug 492831 also adds a content module handler.

I'd like to get an idea of how these patches overlap, so we can try to minimize the complexity and amount of code we add to Fennec.

Ben - can you look at this patch to see how it overlaps with bug 458741. SHIMODA, could you look at bug 458741 as well??
After you both give some feedback on a direction we should take, I'll mark this bug a duplicate of either bug 472426 or bug 458741
(In reply to comment #4)
> After you both give some feedback on a direction we should take, I'll mark this
> bug a duplicate of either bug 472426 or bug 458741

Because, I have a work-in-progress patch for this in bug 472426. I am updating the patch to handle size=1 (dropdown) and size>1 (listbox) elements.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 472426
You need to log in before you can comment on or make changes to this bug.