Sort by Server Timestamp

RESOLVED DUPLICATE of bug 166254

Status

Thunderbird
Folder and Message Lists
--
enhancement
RESOLVED DUPLICATE of bug 166254
9 years ago
8 years ago

People

(Reporter: Martin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: 

As the "sort by order received" option does not work quite well when you move messages between folders, I would very much like to see the option "sort by server timestamp".

How could this be done?
Almost every e-mail has received headers with timestamps in it. My mailserver adds a last received line with its timestamp. Ane one could use that for sorting.

Advantages: 
- If somebody with a wrong system time writes me an e-mail today, I see it between other e-mails I receive today. (That would not be the case if sorting by date.)
- If I move messages between folders, the order would still be intact. (That would not be the case if sorting by received order.)

My pseudo-code:
for all received headers
  if it contains a timestamp
    use that
    break
if no timestamp found
  use fetch timestamp (in "From - " header)
if no timestamp found
  use Date header
 

Reproducible: Always
AFAIK, "Received column"(value is obtained from Received: header) is already implemented by bug 166254 in next Tb 3(still Beta version currently), although it's still doesn't work for IMAP folder(bug 402594). And, at least 8 bugs were DUPed to bug 166254.
Is the new "Received column" not satisfy your requirement?

FYI.
AFAIK, experimental patch for bug 166254(similar to your proposal) was landed on Tb 2. So you can enjoy "Value obtained from Received: header in Date column" with Tb 2, by setting hidden preference. However, it'll produce problem of bug 341548. And, you have to execute "rebuild index" manually for all local mail folders after upgrade to Tb 3.
(Reporter)

Comment 2

9 years ago
Yes, after skimming through the many comments of bug 166254, it seems that they finally agreed on concept that is quite similar to my proposal. Although it is not 100% identical, I guess the implementation of bug 166254 would satisfy my requirement, therefore I will tag my proposal as a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 166254
You need to log in before you can comment on or make changes to this bug.