AJAX / JavaScript output function refresh reloads Java Applet outside output span

RESOLVED INVALID

Status

()

Core
General
RESOLVED INVALID
9 years ago
6 months ago

People

(Reporter: unixgamerocker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10

Here we have a very odd problem on a simple page with two things:
1) A java applet for a web radio in its very own div.
2) The currently playing information for said web radio inside its own span, which is checked on a 15 second delay and updated when the information changes via javascript.

The javascript output is directed at the span for #2 but somehow #1 is affected.

Reproducible: Always

Steps to Reproduce:
1. Make sure Java is installed.
2. Make sure Javascript is enabled.
3. Visit http://magfest.org/magradio2.html (warning: automatic audio playback)
Actual Results:  
Every 15 seconds, the Java applet (which is not inside the javascript's output span!) reloads, possibly indicating a output boundary problem?

Expected Results:  
The javascript should only refresh stuff inside the "nowplayer" span, which the applet is outside. The applet should never refresh in the current code example. Since the *only* thing changed from the (first) working example to the (second) not working example is the actual HTML produced, one might think the html is the problem, but it doesn't appear to be bad html. However, even bad HTML should not cause javascript to output outside of a span when one is specified.

OTHER BROWSERS
With IE7, the table refreshes constantly (unexpected) but the applet stays put.
With Safari, table refreshes as expected, and the applet stays put as expected.

When life was simple and we just wanted to refresh the current name of the track -- example at http://magfest.org/magradio.html -- things were beautiful. This page refreshes the currently playing song from http://magfest.org/playing.php and the data at that URL only changes when the song changes.

Now, add a nice table with more playing information and such -- the result being at http://magfest.org/magradio2.html -- and everything works properly EXCEPT the Java Applet, which is refreshed every 15 seconds (the frequency of the check for updated information from the page mentioned below). This page refreshes its information from http://magfest.org/mpl.html and the data there ALSO only changes when the song changes. 

All machines are using the latest Sun Java available (1.6.0_13).

Also tested with Firefox/3.0.10 on Linux (x64).
Also tested with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)
Assignee: general → nobody
Component: JavaScript Engine → General
QA Contact: general → general
The HTML <applet> element and related java functionality was removed from Gecko in Bug 1279218. Marking related bugs as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.