Closed Bug 494064 Opened 11 years ago Closed 11 years ago

History > Recently Closed Tabs and Recently Closed Windows should show the URL on the Status Bar if I hover the mouse on an entry in the list of closed tabs and windows

Categories

(Firefox :: Menus, enhancement)

3.5 Branch
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 436758

People

(Reporter: bugdickvl, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10

I recently noticed that Bug 88541 (Show URI in status bar onmouseover of Back/Forward menu items) got fixed and I wondered why we still haven't that feature for items in the "Recently Closed Tabs" and "Recently Closed Windows" list. I always miss that when I want to undo a closed tab.
An indication of how many History items each entry has would also be awesome, like having a second level list opening with all the History items of that Closed Tab (but that may be something for another feature request).




Reproducible: Always

Steps to Reproduce:
1. Open a few tabs with some sites (e.g. Support forum index pages 1-5) that have the same title
2. Close them all with a middle-click on that tab in some random order.
3. Try to find a particular tab with the wanted URL (forum index page) in the Recently Closed tabs list. All have the same title, so all I can do is to restore them until I find the wanted tab.
Actual Results:  
If I hover an entry in the Recently Closed Tabs list then I see no URL on the Status Bar to help me find the one I'm looking for.

Expected Results:  
The Status Bar should show the URL of the item that I hover in the Recently Closed Tabs list, so I can identify the one I'm looking for quickly.
Component: Bookmarks & History → Tabbed Browser
QA Contact: bookmarks → tabbed.browser
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted-firefox3.6?
Over to menus, although arguably this belongs in either History or Session Store. Fix should be relatively easy...
Component: Tabbed Browser → Menus
QA Contact: tabbed.browser → menus
Version: unspecified → 3.5 Branch
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 436758
Flags: wanted-firefox3.6?
You need to log in before you can comment on or make changes to this bug.