History sidebar is slow to populate and causes Shiretoko to freeze while doing so.

RESOLVED DUPLICATE of bug 417262

Status

()

--
major
RESOLVED DUPLICATE of bug 417262
10 years ago
9 years ago

People

(Reporter: geeknik, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TSnappiness])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090520 Shiretoko/3.5b5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090520 Shiretoko/3.5b5pre

The history sidebar in Shiretoko is slow to populate despite all of the recent history fixes that have landed. When I first open Shiretoko after the browser has been closed, it took 10-12 seconds (not scientifically measured) for the sidebar to populate.  After the browser has been open and the sidebar has been opened/closed a few times, it takes 5-6 seconds to populate the sidebar. I don't know if this is the default, but my history sidebar opens to "By Last Visted" by default. Changing to "By Most Visited" takes approximately 6 seconds and causes Shiretoko to freeze up while it's populating. Changing to "By Date" takes about a second to populate, as does changing to "By Date and Site" but changing to "By Site" takes 2-3 seconds and also causes Shiretoko to briefly freeze up.

Reproducible: Always

Steps to Reproduce:
1. Open Shiretoko.
2. Press ctrl-h on your keyboard.

Actual Results:  
Wait up to 10 seconds (or longer) for the history sidebar to populate.

Expected Results:  
The history sidebar should have the same speed as the History window located @ History->Show All History.

My places.sqlite is 73,572KB in size and the history days back to 4 February 2009.
(Reporter)

Updated

10 years ago
Severity: normal → critical

Comment 1

10 years ago
mostly dupe of bug 417262. We are aware of those slowdowns, 3.0 is probably not faster there.

Updated

10 years ago
Severity: critical → major
Version: unspecified → 3.5 Branch

Updated

9 years ago
Whiteboard: [TSnappiness]

Comment 2

9 years ago
History sidebar has the same speed as History-Show All History IF they are sorted the same way. 

I mean, History sidebar can be slow if you got a large browser history AND History sidebar is not grouped "By Date". Grouping "By Date" means a few elements in sidebar while grouping "By Last Visited" or "By Most Visited" means lots of elements in sidebar. Lots of elements means slower. 

History-Show All History URLs are ALWAYS grouped "By Date".

So, for me (Firefox 3.5.2 on Windows XP) History sidebar is as fast as History-Show All History.
i'm goin to dupe this, if you have further infos additional to those present in bug 417262 please report them there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 417262
You need to log in before you can comment on or make changes to this bug.