deck of iframes always draws last iframe

RESOLVED FIXED in Future

Status

()

Core
XUL
P3
normal
RESOLVED FIXED
18 years ago
10 years ago

People

(Reporter: Nathan Rogers, Assigned: Eric Vaughan)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
When I put a deck with several iframes as children in my chrome, mozilla always
draws the last child, regardless of the deck's index attribute.

For example,
<deck index="0">
  <iframe src="http://dmoz.org"/>
  <iframe src="http://mozilla.org"/>
</deck>
will show mozilla.org rather than dmoz.org as it should.

It's possible to work around this by enclosing each iframe in a separate box,
and I haven't had trouble with decks of anything else.

This worked fine under M16, but it is broken under M17 and the nightlies.

Comment 1

18 years ago
This is effectively bug 32155, but for decks not stacks. This will not be
addressed before NS6 ships, based on bug 32155. Setting target milestone to
Future (unless trudelle disagrees).

(By the way, actually, I'm surprised that the workaround works).
Assignee: trudelle → evaughan
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → Future

Comment 2

18 years ago
Created attachment 13093 [details]
simple testcase of two iframes in a deck (and repeated with <box> around <iframe>) [text/xul]
(Reporter)

Comment 3

18 years ago
Created attachment 13099 [details]
test case, can load by clicking in mozilla
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

18 years ago
fixed

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.