Last Comment Bug 494089 - Hard freeze when visiting the above site even in safemode. Very high CPU usage also.
: Hard freeze when visiting the above site even in safemode. Very high CPU usa...
Status: RESOLVED FIXED
: top500
Product: Core
Classification: Components
Component: Layout: Floats (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
http://atlanta.braves.mlb.com/index.j...
Depends on: 494332
Blocks: 25888
  Show dependency treegraph
 
Reported: 2009-05-20 17:43 PDT by Larry Snow
Modified: 2010-12-17 07:00 PST (History)
15 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Larry Snow 2009-05-20 17:43:13 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090520 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090520 Firefox/3.0.10

When visiting the above site even in safemode the browser freezes and the CPU usage rises.  Has to be terminated.

Reproducible: Always

Steps to Reproduce:
1. Visit http://atlanta.braves.mlb.com/index.jsp?c_id=atl
2. Page begins to load and then freezes.
3. CPU usage also goes up significantly and the browser does not respond.
Actual Results:  
Freezes.

Expected Results:  
Loads normally.
Comment 1 Mardeg 2009-05-20 17:50:04 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Visited the site in safe mode, disabled javascript and all plugins from Tools -> Add-ons, "Plugins" section, no freezes and the CPU was at 0% with infrequent spikes of 3%
Comment 2 Mardeg 2009-05-20 17:54:07 PDT
Enabled javascript and reloaded, back to 0% which just leaves plugins.
Larry can you see if disabling all plugins gives the same result?
Comment 3 Larry Snow 2009-05-20 18:01:49 PDT
Yes Madeg it does.  I disabled everything and still get the freeze.
Comment 4 Larry Snow 2009-05-20 18:04:37 PDT
BTW, MLB's main site works, but all the individual team sites do not.
Comment 5 Larry Snow 2009-05-20 18:08:06 PDT
Madeg, you are using Shiretoko.  That does work.  My bug is for Minefield.
Comment 6 John 2009-05-20 19:44:23 PDT
This works for me, but I am experiencing a similar hang on the iGoogle homepage and on upload filesystem dialog boxes/ downloads. It started a few days ago, but I don't have an exact date.
Comment 7 IU 2009-05-20 21:55:34 PDT
(In reply to comment #5)
> Madeg, you are using Shiretoko.  That does work.  My bug is for Minefield.

You should change "Version" to specify "Trunk"
Comment 8 (mostly gone) XtC4UaLL [:xtc4uall] 2009-05-21 02:48:43 PDT
this is WFM using
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090520 Minefield/3.6a1pre ID:20090520041818
no matter what the UA is. i also tried other team sites.
Comment 9 Ria Klaassen (not reading all bugmail) 2009-05-21 09:49:39 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090519 Minefield/3.6a1pre

Is indeed a site with 100% CPU on this computer probably because of the flash, but no hangs so far. Do you have the latest flash version?
Comment 10 Larry Snow 2009-05-21 11:50:53 PDT
I have the latest flash and am now using today's build and it still freezes.  Littlemutt also confirmed this.  I've been going to that site everyday and never a problem.  Now it freezes even in safemode.  Something is wrong.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090521 Firefox/3.0.10 ID:20090521043940
Comment 11 Larry Snow 2009-05-21 12:07:38 PDT
The nightly build for 5/20 (ID:20090520041818) works fine, but the nightly build for 5/21 does not work.
Comment 12 John 2009-05-22 15:43:54 PDT
This used to work for me, but ever since 5/22, all the MLB teams individual team pages cause a hang.

Can anyone else reproduce this 100%? If so, can we bump the severity to critical, since it's a hang.
Comment 13 Priit Uring 2009-05-25 04:42:29 PDT
Windows 7 and Minefield 20090524 Freezes completely!
Flash and ads are blocked ( ADblock plus and Flashblock extensions )
Jit.Chrome and Jit.Content also enabled
I am using P4 HT enabled 3.0GHZ CPU and Process Explorer v11.33 shows that Minefield CPU usage doesn't go beyond 50% or lower than 46% and no I/O bytes.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090524 Firefox (.NET CLR 3.5.30729)

If needed I can give pictures and try newer builds!
And has some1 experienced this Freeze up on Linux or Mac ?
Comment 14 Ria Klaassen (not reading all bugmail) 2009-05-25 07:22:59 PDT
This bug has the same regression range as Bug 494503. I don't know if it is the same issue.
Comment 15 philippe (part-time) 2009-05-25 07:37:51 PDT
Hangs on my Mac (OS X10.5.7) as well. The stack looks similar to the one I had from bug 494503. I have my minimum font-size set to 12px (the font-size maters in bug 494503)
Comment 16 Bill Gianopoulos [:WG9s] 2009-05-25 11:47:27 PDT
From hg bisect, definitely a regression from bug 25888:
Comment 17 Bill Gianopoulos [:WG9s] 2009-05-25 11:51:37 PDT
for the record, since there seemed to be 3 checkins for bug 25888, the one hg bisect identified as the culprit was:

The first bad revision is:
changeset:   28618:be75e40365ce
user:        L. David Baron <dbaron@dbaron.org>
date:        Wed May 20 07:21:34 2009 -0400
summary:     Fix bug 25888 for inline frames other than bullets:  redo line reflow when the line's height pushes it into the way of other floats.  (Bug 25888)  r+sr=roc
Comment 18 David Baron :dbaron: ⌚️UTC-10 2009-06-10 11:57:22 PDT
This is fixed by the patch I'll attach to bug 494332 shortly.
Comment 19 Larry Snow 2009-06-10 18:34:04 PDT
Thanks David.
Comment 20 philippe (part-time) 2009-06-19 22:11:35 PDT
This is indeed FIXED since the patch for bug 494332 landed.

Note You need to log in before you can comment on or make changes to this bug.