If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Dragging link into text input breaks drag and drop

RESOLVED WORKSFORME

Status

()

Core
Drag and Drop
P3
normal
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Jeffrey Baker, Assigned: Blake Ross)

Tracking

({helpwanted})

Trunk
Future
x86
Linux
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Tested on Linux build 2000-08-17-13.  If you drag and drop a link into a text
input, that link can no longer be dragged properly.  To reproduce:

1) Open two mozilla windows at http://bugzilla.mozilla.org/
2) From window 1, drag any link into the bug number input box in window 2
3) From window 1, drag the same link into the content area of window 2

Notice that window 2 doesn't navigate to the link, like it should

4) From window 1, drag any other link into the content are of window 2

Notice that window properly proceeds to open the dropped link.  The same
behavior can be observed with any <INPUT> or <TEXTAREA> element.
I am seeing this too on Linux build from a couple of days back.

What seems to be happening is that the second drag and drop is actually a copy
paste of the link text. You can confirm this by selecting some text, then middle
click on the content area of the second window.
Summary: Dragging link into text input breaks drag and drop → Dragging link into text input breaks drag and drop link follow
akkan@netscape.com suggested this might be blizzard@mozilla.org's stuff, like a
problem with drag start. Reassigning.
Assignee: joki → blizzard
Summary: Dragging link into text input breaks drag and drop link follow → Dragging link into text input breaks drag and drop
mass assign
Status: NEW → ASSIGNED
This looks a lot like 50639.
Assignee: blizzard → anthonyd
Status: ASSIGNED → NEW

Comment 5

17 years ago
ok, i see what this bug is:

if i drag to the input field of the second window, subsequent drag&drops to the 
content area of the browser do not catch the drop event.  I need to look at this 
more once we have the anonymous content issues resolved with drag and drop.

anthony
Status: NEW → ASSIGNED
Depends on: 51321

Comment 6

17 years ago
I think this should be fixed before we release, so I'm setting this to be m19, 
its not really a performance bug, but it is a useablity breaking problem, and 
its not hard at all to reproduce.

anthony
Target Milestone: --- → M19

Comment 7

17 years ago
moving to future, adding helpwanted, reviewed by Bijal and beppe
Keywords: helpwanted
Target Milestone: M19 → Future

Comment 8

17 years ago
Updating QA Contact.
QA Contact: janc → lorca
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Comment 10

17 years ago
xpapps
blake--if this is an editor bug; please reassign back to editor
Assignee: anthonyd → blakeross
Status: ASSIGNED → NEW
Component: Event Handling → XP Apps: Drag and Drop
QA Contact: gerardok → tpreston
(Assignee)

Comment 11

17 years ago
Works for me (new windows tip).  Reopen if you're still seeing (Linux-
specific?)...
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.