Drag and drop to the URL bar does nothing

RESOLVED WORKSFORME

Status

()

Core
Drag and Drop
P3
normal
RESOLVED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Jeffrey Baker, Assigned: Blake Ross)

Tracking

({helpwanted, regression})

Trunk
helpwanted, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Tested on Linux build 2000-08-17-13.  Dragging and dropping to the URL bar has
no effect.  The expected result is that the link or selection being dragged
would be pasted into the URL bar.  To reproduce, simply drag a selection or link
to the URL bar and drop.  The "+" indicating target lock appears, but nothing is
actually pasted.  The word "OnToplevelDragDrop" appears on the console.

Comment 1

18 years ago
i disagree with the expected result for dragging a link into the url bar.  i 
think the browser should go to the url in the link.  cf bug 36867.
Saw this on NT as well, changing OS to All. By the way, I think this worked once 
when I tested on Linux. Haven't gotten it to work after that, though.

Drag and drop -> pinkerton@netscape.com
Assignee: joki → pinkerton
OS: Linux → All
Assignee: pinkerton → beppe
editor

Comment 4

18 years ago
ok, so the selected URI gets pasted into the location field, but the page is not 
loaded. The pasting should trigger the load. This can wait, setting to future 
and we will address this in the next release
Assignee: beppe → anthonyd
Target Milestone: --- → Future
(Reporter)

Comment 5

18 years ago
No, the problem is that nothing gets pasted into the URL bar at all.  This is on
Linux 2000-08-18-06.

Comment 6

18 years ago
resetting target milestone to ---
Target Milestone: Future → ---

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 7

18 years ago
testing...

Comment 8

18 years ago
this doesnt seem to work on any platforms.  i have a question, did this ever 
work?  the reason i ask, is that pink made some changes to d&d that adversly 
changed the behaviour of d&d with editor, specifically single line text fields 
(which the url bar is).  After I fix the other d&d bug, I will see if this one 
is effected.

anthony

ps. unless if course this never worked, in that case its something different.

pps.  also, someone needs to make a decision about waht the correct behaviour 
here is.

Comment 9

18 years ago
Yes id did work at one time. You could also select a URL in an xterm and drop it
on the main window and it would be loaded. It doesn't work with 2000082221 build.

Comment 10

18 years ago
Yes id did work at one time. You could also select a URL in an xterm and drop it
on the main window and it would be loaded. It doesn't work with 2000082221 build.

Comment 11

18 years ago
odd, on win98 I drag and drop a url into the url bar, it does not drag correctly 
(the current entry in the bar is not removed) but, the drag works.

if i have a uri in the body, select and drag in 4x, it does not allow the drag 
into the location bar, that is on win and mac -- didn't test linux

in 5.0 win allows the drag as stated above, mac does not even allow the drag, 
again I did not test linux

I am still inclined to future this request. 

Comment 12

18 years ago
moving out to future, prompting a load action on drop can be addressed in the 
next release
Keywords: helpwanted
Target Milestone: --- → Future

Comment 13

18 years ago
this is apparently a regression.

anthony
Keywords: regression

Comment 14

18 years ago
Updating QA Contact.
QA Contact: janc → lorca

Comment 15

17 years ago
setting milestone to 0.9, want to try and pick this up for 6.5
anthonyd
Target Milestone: Future → mozilla0.9

Comment 16

17 years ago
futuring for now.

anthonyd
Target Milestone: mozilla0.9 → Future

Comment 17

17 years ago
just a quick comment, you can drag and drop a link to the url bar, and it will 
drop the link location there.  what more is needed? do we want that url to begin 
loading, or have the user hit return to begin the load of the dropped link?

anthonyd
(Reporter)

Comment 18

17 years ago
When I drag a link into the URL bar with either Moz 0.7, or 2001-01-09-08 Linux,
I get the _text_ of the link in the bar, not the URL.  This is clearly broken,
no?

Comment 19

17 years ago
Jeffrey, you might be hitting bug 58122.
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Comment 21

17 years ago
xpapps
blake--let us know if this is actually an editor bug
Component: Event Handling → XP Apps: Drag and Drop

Comment 22

17 years ago
reassign; remove milestone
Assignee: anthonyd → blakeross
Status: ASSIGNED → NEW
QA Contact: gerardok → tpreston
Hardware: PC → All
Target Milestone: Future → ---
(Assignee)

Comment 23

17 years ago
This wfm in a new build.  Selection dnd is broken, but that's a separate bug.  
The link url, not text, is dropped into the urlbar.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.