Set As Desktop Background not available when Prism extension is installed

RESOLVED FIXED

Status

Mozilla Labs
Prism
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Matthew Gertner, Assigned: Matthew Gertner)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
When the Prism for Firefox extension is installed, the Set As Desktop Background option no longer appears in the context menu for images. I suspect this has something to do with the fact that we have our own nsIShellService, but I'll have to look into it.
(Assignee)

Comment 1

9 years ago
Problem is here I guess: http://mxr.mozilla.org/mozillasvn/source/projects/webrunner/extension/build/Makefile.in#59. We definitely shouldn't be copying the nsIShellService.xpt file into the extension.
(Assignee)

Comment 2

9 years ago
Or rather, we should probably rename the interface since there is a single prism.xpt file, and some of the interfaces are used by the extension.

Comment 3

9 years ago
Hy, is this problem fixed already, does anyone even works on it?
(Assignee)

Comment 4

9 years ago
Sorry, I know exactly what causes this problem and how to fix it. Just haven't gotten to it yet. I do consider it a high priority and will make sure a fix gets into the next Prism release.
(Assignee)

Updated

9 years ago
Duplicate of this bug: 460222
(Assignee)

Comment 6

9 years ago
Created attachment 420741 [details] [diff] [review]
Calling this interface nsIShellService was a totally bad idea
Attachment #420741 - Flags: review?(mark.finkle)

Comment 7

9 years ago
When do you anticipate this issue being resolved?
Comment on attachment 420741 [details] [diff] [review]
Calling this interface nsIShellService was a totally bad idea

I'm not a big fan of nsIProtocolShellService. How about nsIWebProtocolService ?

r+ otherwise.
Attachment #420741 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 9

9 years ago
Okay I changed it to nsIWebProtocolService.

Sending        components/public/Makefile.in
Deleting       components/public/nsIShellService.idl
Adding         components/public/nsIWebProtocolService.idl
Sending        components/src/mac/nsDesktopEnvironmentMac.h
Sending        components/src/mac/nsDesktopEnvironmentMac.mm
Sending        components/src/nsPlatformGlue.js
Sending        components/src/windows/nsDesktopEnvironmentWin.cpp
Sending        components/src/windows/nsDesktopEnvironmentWin.h
Transmitting file data .......
Committed revision 59494.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Duplicate of this bug: 532731
You need to log in before you can comment on or make changes to this bug.