Doesn't load at all if ~/.mozilla is a dead symlink

RESOLVED DUPLICATE of bug 237128

Status

()

RESOLVED DUPLICATE of bug 237128
10 years ago
10 years ago

People

(Reporter: yoyoson6, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US) AppleWebKit/525.19 (KHTML, like Gecko) Chrome/1.0.154.65 Safari/525.19
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10

Firefox crashes silently at startup if ~/.mozilla is a dead/dangling symlink. 

I am running firefox from the cmd line. All the firefox versions I tried to run didn't produce any errors or windows and returned to the prompt in less than a second.  

Tried:
3.0.0 beta
3.0.7
3.0.10

The story is I migrated to a new machine but retained my former NIS home directory. The ~/.mozilla directory was actually a symlink pointing to a directory that only existed on the old machine.  

It's a rare occurrence, but the help documentation (http://support.mozilla.com/en-US/kb/Firefox+will+not+start#Firefox_will_not_start_on_Linux) had me chasing red herrings about which version of GTK+ I have installed, etc. 

This may be related to bug 485328. (https://bugzilla.mozilla.org/show_bug.cgi?id=485328)




Reproducible: Always

Steps to Reproduce:
1. cd ~
2. mv .mozilla savethis
3. ln -s /bogusdir .mozilla
4. firefox


Actual Results:  
Nothing! Returned to prompt silently. 

Expected Results:  
Firefox should complained via window, or an error produced at the prompt. 

using RHEL 5.2
looks like a dupe of bug 490597

Comment 2

10 years ago
bug 490597 got duped to bug 237128 (access permissions. It's not exactly the same bug, but it has the same root cause : not being able to load ~/.mozilla . So I'm going to dupe it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 237128
You need to log in before you can comment on or make changes to this bug.