Recurring Events Do Not Take Daylight Savings Into Account

RESOLVED DUPLICATE of bug 357383

Status

Calendar
Provider: ICS/WebDAV
RESOLVED DUPLICATE of bug 357383
9 years ago
9 years ago

People

(Reporter: Rob, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10
Build Identifier: Lightning 0.9, Sunbird pre1.0 2009/05/21

OS: Ubuntu Jaunty 9.04
App: Lightning 0.9 as well as 2009/05/21 nightly of Sunbird

When using remote calendar on our Horde Kronolith WebDAV/ICS server, calendaring does not take into account daylight savings changes on recurring events.  Kronolith web interface, KDE Kontact, Funambol+Outlook, and my Nokia Symbian S60 SyncML client do not exhibit this behaviour, so we have ruled out the Kronolith WebDAV server being the problem.

Reproducible: Always

Steps to Reproduce:
1. Book a weekly recurring event at 14:00 on January 1st, 2009 on a remote WebDAV calendar
2. Subscribe to calendar with Mozilla Lightning/Sunbird
3. Move view to May 2009

Alternately

1. Subscribe to remote calendar in Lightning/Sunbird
2. Book a weekly recurring event at 14:00 on January 1st, 2009 on a remote WebDAV calendar
3. Move view to May 2009
4. Reload remote calendars
Actual Results:  
Event recurs at 15:00.

Expected Results:  
Event should remain at 14:00.

The problem also appears to occur on local calendars.

Comment 1

9 years ago
I just tested with internal storage, no problem. I assume your event gets stored in UTC, could you export your recurring event. Mine is as follows:

BEGIN:VEVENT
CREATED:20090522T062045Z
LAST-MODIFIED:20090522T062102Z
DTSTAMP:20090522T062102Z
UID:dcf1d3c7-20dd-453f-bcb7-ef79bb097cc9
SUMMARY:weekly 1400
RRULE:FREQ=WEEKLY
DTSTART;TZID=Europe/Amsterdam:20090204T140000
DTEND;TZID=Europe/Amsterdam:20090204T150000
END:VEVENT
(Reporter)

Comment 2

9 years ago
Yes, it gets stored in UTC I believe.  After following my steps to reproduce above, this is the exported event:

BEGIN:VEVENT
CREATED:20090522T143138Z
LAST-MODIFIED:20090522T143138Z
DTSTAMP:20090522T143138Z
UID:0f0c0e5c-a79e-4792-bbbd-daf1fcd5b4c3
SUMMARY:Recurring Event UTC Bug
STATUS:CONFIRMED
CLASS:PUBLIC
RECURRENCE-ID:20090603T190000Z
DTSTART:20090603T190000Z
DTEND:20090603T200000Z
TRANSP:OPAQUE
END:VEVENT
(Reporter)

Comment 3

9 years ago
Can anybody else confirm the issue?
I don't see an error (but I have stated the same opinion in other bugs about the same issue, e.g. Bug 357383). 
- the time is fixed at 14:00 UTC
- during standard time the UTC offset is +1 (timezone Europe/Berlin)
- during daylight saving time the UTC offset is +2 (timezone Europe/Berlin)
-> event will be displayed at 15:00 during winter and at 16:00 during summer

I assume that your system uses a timezone that has standard and daylight saving time with different UTC offsets too.
(Reporter)

Comment 5

9 years ago
I see, thanks for the link to the previous bug report.  You are correct; my system is Ubuntu, with a UTC hardware clock and the local timezone in Linux set to America/New_York.

I will mark this as a duplicate and make comments in the Bug 357383.
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 357383
You need to log in before you can comment on or make changes to this bug.