After changing main window Layout the mail content in preview pane is being displayed with wrong encoding

RESOLVED DUPLICATE of bug 265393

Status

Thunderbird
Message Reader UI
RESOLVED DUPLICATE of bug 265393
9 years ago
9 years ago

People

(Reporter: u344248, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090521 Shredder/3.0b3pre ID:20090521031522

Assuming, we have an e-mail with international (non-ascii) characters. After changing the main window layout (to Wide View or Vertical View) while previewing an e-mail, the mail contents is being rendered as if using wrong character encoding, although the View -> Character encoding list has UTF-8 selected.

Reproducible: Always

Steps to Reproduce:
1. click on an e-mail in the list so that the preview shows up
2. change the layout of the main window to Wide View, Vertical View or the classical view
Actual Results:  
After changing the layout while previewing an e-mail, all non-ascii characters in previewed mail are being rendered wrong

Expected Results:  
the mail preview should render properly displaying all non-ascii characters

IMO, the encoding being used for rendering is ISO-8859-1.
(Reporter)

Comment 1

9 years ago
Created attachment 378945 [details]
Mail contents rendered correctly

This screenshot presents the state before changind layout
(Reporter)

Comment 2

9 years ago
Created attachment 378946 [details]
Mail contents rendered incorrectly after changing main windows layout

After changing the layout of the main window, all non-ascii characters aren't readable

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 265393
You need to log in before you can comment on or make changes to this bug.