All users were logged out of Bugzilla on October 13th, 2018

Installation confirmation pop-up wont auto-focus for the featured add-on-"morning coffee"

VERIFIED FIXED in 5.0.6

Status

VERIFIED FIXED
10 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Assigned: abuchanan)

Tracking

unspecified
5.0.6
x86
Mac OS X

Details

(Reporter)

Description

10 years ago
steps to reproduce:
1.Go to the home page-https://preview.addons.mozilla.org/en-US/firefox/
2.In the introductory section for anonymous users,click on "News" section
3.Click "add to firefox" button for the add-on,"Morning coffee"
4.Notice the installation confirmation pop-up

expected result:
Installation confirmation pop-up is auto-focused

actual result
Installation confirmation pop-up wont auto-focus for the featured add-on-"morning coffee".Click on the pop-up box will start the count-down to install

screencast:http://screencast.com/t/5HIeSwujraz

additional info:Installing the same add-on from its details page,works fine.
I can't reproduce this on OS X or linux.
I can reproduce using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10; I see the same thing Krupa does, and you get two installTrigger()-called windows, which is bug 494282 (probably the same underlying cause).
I still can't reproduce but it probably is the same thing.  Alex is looking at the other one so will probably fix this at the same time.
Assignee: nobody → buchanae
(Assignee)

Comment 4

10 years ago
This should be fixed with bug 494282, r26279

I think both bugs were caused by the same problem, which bug 494282 has patched and committed.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

10 years ago
verified
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.