Firefox should remember saved login info for a domain with and without the www prefix automatically

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
10 years ago
2 years ago

People

(Reporter: geeknik, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090521 Shiretoko/3.5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090521 Shiretoko/3.5pre

When you save login info for www.domain.com in Firefox, Firefox doesn't recognize that domain.com is the same site and as such, there is no saved login information when I try to login to domain.com, so I have to save the password twice.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox
2. Log in and save the login info for www.domain.com
3. Visit domain.com w/o the www prefix.
Actual Results:  
Firefox doesn't have a password saved for the domain.com w/o the www prefix.

Expected Results:  
Firefox's password manager should be able to tell that www.domain.com and domain.com are the same site.

Comment 1

9 years ago
+1

Ok, here is the problem. In theory domain.com w/o the www prefix are not always the same site. www can, like any subdoman, point to some other place.

But i find this annoying to, i would prefer a preference that allow you to:
1) access the password for both www.domain.com and domain.com.
2) access the password for both http://www.domain.com and https://www.domain.com.

Some times it takes me 4 try to get it right with www and https to auto-fil the pass.

A preference in the password manager, site by site or a global setting would just be so useful. :)

// Pontus Thor
(Reporter)

Comment 2

9 years ago
I know that there are some extensions that provide this capability, so I'm changing the bug importance to enhancement. Not sure where this should actually go, so leaving in Firefox:General for now. I expect a WONTFIX due to the availability of extension that provide the functionality, however, I believe this should be built into the browser. 99% of the time, http://www.domain.com is the same as http://domain.com.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → Trunk
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.