Closed Bug 494431 Opened 11 years ago Closed 11 years ago

Need a decent shell for automated testing under WinCE / WinMobile

Categories

(Firefox for Android Graveyard :: General, defect)

All
Windows Mobile 6 Professional
defect
Not set

Tracking

(Not tracked)

VERIFIED INVALID

People

(Reporter: wolfe, Unassigned)

Details

(Keywords: mobile)

There is no shell included in WinCE / Windows Mobile by default. 

There needs to be some way for us to transfer files to a WinCE / WinMobile device, as well as run commands on the device itself so we can examine test case output for success/failure.

First attachment is a CAB file for installing a RLOGIND and some associated utilities.  Here is a listing of the executables available in this CAB: cat, date, df, free, ftpd, getip, kill, ping, ps, reboot, rlogind, rshd, run, seriald, shish, and tail

Install the CAB on your device, then reboot your device.  You should then be able to issue a "rlogin IP_ADDRESS_OF_YOUR_DEVICE" command and open a "shish" shell.
First pass at a SHISH CAB file to install SHISH onto device is located at http://people.mozilla.com/~jmaher/fennec/shish.CAB

Copy CAB to device, run to install.  Reboot device and there should be a rlogind.exe running.  You can connect to the device by typing "rlogin IP_OF_YOUR_DEVICE" at a mozilla-build shell on your PC

Also, ActiveSync connected devices have the IP address of 169.254.2.1, while the host has the IP address of 169.254.2.2

A great tool for finding out the IP address of a device (as well as a LOT of other useful information and control over the device) is the DotFred FDCSoft Task Manager (http://www.dotfred.net/TaskMgr.htm).  Download it and install it on your device - you will thank me later!
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
marking as verified.  We are working with a few different tools right now and making further progress finally!
Status: RESOLVED → VERIFIED
sorry for bug spam.
Many of the bugs which are marked invalid, I see comments telling it occurred in one version or other. But later it was fixed due to 1) by backingout the patch which made regression or 2) by fixing some other bug.
So if we can identify the bug/patch/reason then we should state that and mark those as FIXED. If not mark as WORKSFORME in that case.
Component: Windows Mobile → General
QA Contact: mobile-windows → general
Hardware: ARM → All
You need to log in before you can comment on or make changes to this bug.