Problem refreshing URL's with commas in (e.g. StoryServer cURL's)

VERIFIED DUPLICATE of bug 45143

Status

P3
major
VERIFIED DUPLICATE of bug 45143
19 years ago
14 years ago

People

(Reporter: dave532, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
At The Guardian I'm implementing a set of sidebar panels for Mozilla / Netscape
6. I conducted a prototype last night which can be accessed using the link in
the URL field (note the images are off other sections of the site as no custom
images have been made - no filing bugs with the panel as it's only a prototype ;)).

The Problem:
The actual URL of the sidebar component is:
http://www.footballunlimited.co.uk/Com/moz_sidebar/0,7575,,00.html
This page contain a META tag to refresh the page:
<META HTTP-EQUIV="REFRESH" CONTENT="300; URL=/Com/moz_sidebar/0,7575,,00.html">

Leaving the sidebar panel running produces a 404 error on the refresh (and the
GU sorry page appears which is out default sorry page). It turns out that in the
refresh tag it ignores everything from the first comma so it tries to take you
to http://www.footballunlimited.co.uk/Com/moz_sidebar/0

As we use the StoryServer CMS to generate our pages we need the refresh tags to
support commas in the urls as this is what StoryServer uses to identify pages.
The bug will also affect any other areas of the site where we use meta refresh
tags and will similarly affect meta refreshes with other storyserver sites such
as www.sportal.com who may wish to do similar (as well as any other people who
use commas in URL's).

I'd say due to the severity of this (we'll be unable to release sidebars for
Mozilla / Netscape 6 until this is fixed) then this bug needs to be fixed for
the Mozilla 1.0 and Netscape 6 release whichever comes first.

I'll attach a mimimal testcase in a minute. Sorry I'm not sure what component to
assign to (please note: this is NOT exclusive to the sidebar but it is where I
discovered this bug). Netscape 4.x and IE don't suffer from this bug. The
testcase will refresh to a URL that doesn't exist but you can easily tell from
the error message that it's ignored everything in the URL after the first comma.

BUILD ID: 2000081704
Platform: WinNT 4.0
also occurs on N6b2 MacOS9 so assuming XP bug.
(Reporter)

Comment 1

19 years ago
Created attachment 13117 [details]
META refresh tag with URL containing commas

Comment 2

19 years ago
There is already a bug about this (bug 45143), the problem is that we take the
comma as a separator between urls because some of the top 100 web page creators
can't read the spec and using it as such. There seems to be a patch to this.

*** This bug has been marked as a duplicate of 45143 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

19 years ago
Yep, gonna get some coffee, take a final look at my patch, and then upload it.
Verifying duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.