If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[PP] install.exe builds do not work - can't load sdinst.dll

VERIFIED FIXED in M4

Status

SeaMonkey
Installer
P1
critical
VERIFIED FIXED
19 years ago
13 years ago

People

(Reporter: pmock, Assigned: Sean Su)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build: April 9 win32 optimized build on Win98/WinNT 4.0 SP4

Problem: Can not install the April 9 build.  The installation
program aborts with error message "!Could not load sdnet.dll"
The problem occurs on Win 98, Win95, and Win NT.  Two other QA
engineers has run into this problem.

I searched my hard drive and can not find this .DLL file.

Steps to reproduce problem:
1) Download the April 9 Optimize build
   You download the new "install.exe"
2) Run install.exe
3) Go through the install wizard
   On the last screen where it goes to start the copy process,
   it will abort with the error "Could not load sdinstall.dll"

Note: Fenella Gor was the only Mail QA person to successful get the
install program to run.  Ninoschka, Laurel, and I could not get
the program to complete successful.

This could be a potential M4 stopper.

Comment 1

19 years ago
The reason I was able to install it is because I let it to install into the
default directory, which is Program Files/Netscape/Seamonkey/.  But if
you force it to install into another directory from the root, it has this
problem.
However, it did allow me to create a subdirectory under
Program Files/Netscape/seamonkey/ and install successfully.
Note: If this is not a bug, suggest to have release note on this problem
(Reporter)

Comment 2

19 years ago
Thanks Fenella.  That's make more sense now.  I will give your suggestion a try.
 The reason I didn't want to choose the default director is that I had 4.5.1
installed there.  I guess I will either rename my directory or de-install.

Comment 3

19 years ago
Stopper?  I think so. cathleen or sean, if you agree, pls mark it M4 target
milestone.

This is a new installer added into the recent M4 candidate builds.

Updated

19 years ago
Severity: major → critical
Priority: P3 → P1
Summary: Can't install April 9 build - can't load sdinst.dll → install.exe builds do not work - can't load sdinst.dll
Target Milestone: M4

Comment 4

19 years ago
install.exe has not work on any build yet.  April 12 was looked at too, and
still does not work.
(Reporter)

Comment 5

19 years ago
Sean was able to duplicate the problem on my machine.  We found the problem
occurs when you use the Browse button to specific a different location where to
install the Seamonkey build.

Work around: instead of using the browse button to navigate to the directory
where you want to install, manually type in the path.

Sean thinks he knows how to fix the problem.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

19 years ago
The fix has been checked in.
I've tested the fix against Peter's and Fanella's machine.

This was approved by Chris Hofmann.
(Reporter)

Updated

19 years ago
Summary: install.exe builds do not work - can't load sdinst.dll → [PP] install.exe builds do not work - can't load sdinst.dll
(Reporter)

Comment 7

19 years ago
Updating summary title.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

19 years ago
Verified with the April 14 build (1999-04-14-12-M4) on Win32 NT 4.0 SP4
Win98, and Win95.
In the installation program, I was successful in changing the default location
and completing the installation.  To verify, I launched Apprunner then Messenger
to verify it was installed correctly.

Ninoschka Baca did the install on Win95 and it ran ok. Thanks Ninoschka.

Comment 9

18 years ago
Updating component from Install Wizard to Installer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.