If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

data: URIs break the Jetpack Features database

RESOLVED DUPLICATE of bug 496197

Status

Mozilla Labs
Jetpack Prototype
--
critical
RESOLVED DUPLICATE of bug 496197
8 years ago
8 years ago

People

(Reporter: sephr, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.10) Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10 GTB5
Build Identifier: 

Upon adding a Jetpack Feature via a website that has it in a data: URI, about:jetpack becomes completely broken. I found out that deleting the Jetpack database solved the problem so I assume that data: URIs are handled incorrectly somewhere before being put in the database.

If there is a way to default to the latest JavaScript version without

Reproducible: Always

Steps to Reproduce:
1. Make an html file with <link rel="jetpack" href="data:application/javascript,//some-code"
Actual Results:  
Jetpack Feature doesn't work and about:jetpack becomes broken.

Expected Results:  
Jetpack Feature works as expected and about:jetpack still works as intended.

Comment 1

8 years ago
Thanks for the report!  For now, using data: URIs is a bit problematic because of the fact that the original HTML page from which a Jetpack's code href is found isn't checked during the auto-update process--which means that whenever the data: URI changes, the changes won't ever result in an auto-update for users of that Jetpack for the time being.

So for now, we'll just disable the ability to subscribe to data: URIs entirely:

  http://hg.mozilla.org/labs/jetpack/rev/8a361aefc2bc

I'm marking this bug as a duplicate of the more general issue that data: URIs are unsupported as Jetpack code URLs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 496197
You need to log in before you can comment on or make changes to this bug.