Closed Bug 494565 Opened 13 years ago Closed 12 years ago

Adding new contact to mailing list break "ok" button

Categories

(Thunderbird :: Address Book, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Aureliano, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090522 Lightning/1.0pre Shredder/3.0b3pre ID:20090522031405

1. Adding new contact to mailing list. 
2. Double click on new contact for edit.
3. Make some change and click on "ok" button for close property page: the button not work!

After if you close address book window and restart him, all work fine: probably it is a refresh problem.

Reproducible: Always
Another STP:

1. Adding a new contact to address book with only firstname  and email: AB compile automatically DisplayName;
2. Add this account to existing mailing list;
3. Open this account from mailing list (double click on item on mailing list);
4. firstname is blank and "Ok" button not validate existing account: the button not work;
5. Close address book window and restart him: firstname is "magical" rewrite and all work fine.
I can't confirm that, but if i remove a contact, that isn't reflected in the list shown until i click elsewhere, and click the mailing list again.
(In reply to comment #2)
> I can't confirm that, but if i remove a contact, that isn't reflected in the
> list shown until i click elsewhere, and click the mailing list again.

With release

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090620 Lightning/1.0pre Shredder/3.0b3pre ID:20090620031524

I can't reproduce my old issue...

WFM now.
...update:

Changed STP (>= Shredder/3.0b3pre ID:20090620031524)

1. Adding a new contact to address book with only firstname  and email: AB
compile automatically DisplayName;
2. Add this account to existing mailing list;
3. Open this account from mailing list (double click on item on mailing list): firstname is blank and "Ok";
My original issue is fixed as on comment #3.

If in the next version the issue in comment #4 still exist I open an other bug.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.