If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Page rendering is broken when background image is too large (www.wreckracing.com)

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Jay Summet, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-30], URL)

Attachments

(1 attachment)

957 bytes, application/octet-stream
Details
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090522 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090522 Minefield/3.6a1pre

When going to the www.wreckracing.com website, the website starts to render and then the browser crashes. Tested with the 1.9.2a1pre build as well as the Mozilla Firefox 3.0.10 that comes with Ubuntu 9.04 by default.

Reproducible: Always

Steps to Reproduce:
1.Go to www.wreckracing.com
2.
3.
Actual Results:  
Entire browser crashes.

Expected Results:  
Rendered the webpage, or at least given an error about invalid HTML. Not crashed.

Comment 1

8 years ago
WFM, unable to reproduce crash
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090522 Minefield/3.6a1pre
Jay, if the minefield build is from mozilla then you can put about:crashes into the address bar, enter, and drag the links to a comment here.
(Reporter)

Comment 2

8 years ago
Sigh...after submitting the bug report, I deleted the minefield build. So I went and re-downloaded it, and I can't make the thing crash again! (although the website does render horribly) [It still crashes on the default 3.0.0.10 build from Ubuntu.]  The version of minefield did not change between downloads
rv:1.9.2a1pre) Gecko/20090522, and I don't know what did change...
This is caused by background image http://www.wreckracing.com/themes/wreckracing/bg.png that is too large (2x60000 px). It is referenced in style.css:

body {
  color: black;
  background: #FFFFFF url(bg.png) repeat-x;
}

The crash bas been fixed in bug 424333 but rendering of the page is broken. I've created a testcase to show that. Everything is OK when the large image is used in img tag (imgsrc.html in the testcase). Rendering is broken when the image is set as background image (background.html) or when the image is specified directly in the URL bar (x_32768.png).

I'm not sure how to fix this, but if it is a problem to handle such large image in these situations then the image should be ignored instead of breaking whole page.
Severity: critical → major
QA Contact: general → thebes
Summary: Entire browser crashes and burns when opening the www.wreckracing.com website → Page rendering is broken when background image is too large (www.wreckracing.com)
Version: unspecified → Trunk
Created attachment 381651 [details]
testcase
QA Contact: thebes → general
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You may also wish to try with the latest Firefox 4 beta, http://www.mozilla.com/en-US/firefox/all-beta.html.
Whiteboard: [CLOSEME 2011-1-30]
(Reporter)

Comment 6

7 years ago
I have tested with 3.6.13 using the testcase provided by Michal Novotny ( attachment 381651 [details]) [as the original website has had it's image fixed already].

I saw no problems with the rendering, so I believe this bug has been quashed!
Thanks all!
Jay
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.