Feature request: check network connection before restoring tabs

VERIFIED DUPLICATE of bug 339678

Status

()

Firefox
Session Restore
--
enhancement
VERIFIED DUPLICATE of bug 339678
9 years ago
9 years ago

People

(Reporter: Dotan Cohen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10

Often when opening Firefox the user may not have yet established a network connection (laptop wifi, for instance). In this case Firefox will try to restore the tabs, but with no network this is obviously not possible. I suggest a feature that checks for a working network before restoring tabs.

Reproducible: Always

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 339678
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.