Page loads with 3.0.10 but not trunk (not UA sniffing)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: u88484, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
The page in the URL loads fine using 3.0.10 but does not load using the latest trunk.  Minefield thinks for about five seconds and then nothing.  Spoofing the user agent in Minefield does not help.

With 3.0.10, the page shows as test/html, Standards compliance mode, UTF-8, 14.84 KB (15,200 bytes)

With trunk, the page shows as test/plain, Quirks mode, ISO-8859-1, 0 KB (0 bytes)
(Reporter)

Updated

10 years ago

Comment 1

10 years ago
This WFM in Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090523 Minefield/3.6a1pre (.NET CLR 3.5.30729) ID:20090523042428. I get standards compliance mode in trunk too.
(Reporter)

Comment 2

10 years ago
Ahh this is going to suck to figure out.  Does not load with all add-ons including plugins disabled but does work with new profile.
Then it's a pref? Does renaming prefs.js make it work?
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> Then it's a pref? Does renaming prefs.js make it work?
Renamed user.js and page doesn't load.  Renamed prefs.js and the page loads.
I had previously toggled JIT, so this isn't a TM issue.
(Reporter)

Comment 5

10 years ago
Figured out it is caused by this pref

user_pref("intl.accept_languages", "en-US,en,chrome://global/locale/intl.properties");

I have no clue what the pref is for or why it is set this way.
(Reporter)

Comment 6

10 years ago
Created attachment 379471 [details]
Contents of intl.properties

Not sure why it is all on two lines but I didn't want to manually edit it.

Comment 7

10 years ago
Your pref is corrupted, no idea why. I don't have a trunk build to verify, it works for me on a shiretoko with weird values for accept_lang. Nothing l10n specific AFAICT, un-CC-ing myself again.
The page load fine for me in trunk
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.