Personas doesn't change the status bar background with Windows classic style

RESOLVED DUPLICATE of bug 487711

Status

Mozilla Labs Graveyard
Personas Plus
RESOLVED DUPLICATE of bug 487711
9 years ago
2 years ago

People

(Reporter: Siyivan, Assigned: Chris Beard)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: 

Personas change the background of the window, and also the text color used on menus, buttons...  to adapt to the background.
However, it also changes the text color of the status bar, whose background didn't change. A good foreground color with one background is not necessarily right with another one. Thus, if personas isn't changing the background, it shouldn't change the foreground either.

Reproducible: Always

Steps to Reproduce:
1. Go to 
2. Put you a which changes the text color, such as http://www.getpersonas.com/persona/816

Actual Results:  
The status bar is white over gray and is hardly readable.

Expected Results:  
Since the status bar background doesn't change, it's text color shouldn't change.
Personas does actually change the background color of the status bar.  If you aren't seeing that, are you using a non-default Firefox theme or a non-default operating system theme by any chance?  Non-default themes are usually the cause of such problems.
(Reporter)

Comment 2

9 years ago
Thanks Myk.
I have checked it on a clean profile, and found out that personas does change the background color on Windows, but doesn't when using the Windows Classic Style (Windows theme, not Firefox).

Updating summary.
Summary: Personas shouldn't change the status bar text color → Personas doesn't change the status bar background with Windows classic style
Ah, great, thanks for confirming that!  In that case, this is actually a duplicate of bug 487711, which is about supporting alternate OS themes generally, as the fix for this problem is not specific to the Classic theme nor the statusbar.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 487711
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.