Mouseover effects within a single element flicker as cursor passes over different types of content within that element.

VERIFIED WORKSFORME

Status

()

Core
Event Handling
P3
normal
VERIFIED WORKSFORME
18 years ago
16 years ago

People

(Reporter: Val Sharp, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)
BuildID:    2000080712

The attachment consists of two tables, each with one cell whose background 
changes color on mouseover, and back on mouseout.

The cell contains a couple of paragraphs of image and text boxes.

Mousing over the cell does not change the background in a smooth and consistent 
manner.

Reproducible: Always
Steps to Reproduce:
Main Problem:

1. Observe how, when you mouseover the cell from one item to the next, crossing 
box boundaries, the background flickers. 

Two further Oddities:

2. In the first table, note that on *first/re-* loading the attachment, before 
any mouseover event has been triggered, one can enter the cell padding, and even 
pass between the paragraphs, without triggering the mouseover event.

3. The second table is the same as the first, except text has been added so that 
it wraps onto the next line. Repeating step #2, notice here that the wrapped 
text background will change.
(Reporter)

Comment 1

18 years ago
Created attachment 13133 [details]
Tables with mouseover to change background.
Reassigning to karnaze, looks like the frames that make up the table cell border
aren't sending events to the right content object, or something like that...
Assignee: jst → karnaze

Comment 3

18 years ago
Confirming the bug with 2000081608 WinNT. Please note the different behaviour
when you move the mouse cursor first in the lower and upper cell.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

18 years ago
In M18, the background problem appears to be resolved - no discontinuities for 
mouseover on any part of cell.

However, cell padding problems have been introduced, such that mouseover-ing 
either cell soon after reload often causes all except left padding to be lost.

(I notice also that the first line of text in each paragraph is slightly 
misplaced but re-aligns itself shortly after loading - will look into this and 
perhaps report as separate bug.)

Comment 5

18 years ago
Cell padding disappearing might be bug 40828, which was fixed recently.

Comment 6

18 years ago
*** Bug 66222 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Component: DOM Level 0 → Event Handling

Comment 7

18 years ago
The attached testcase now worksforme on 2001030110 Win2k.
http://www.informatik.uni-bonn.de/~prosec/inkonetz/personen/index.html (the menu
bar with the names) does not work, though. Is this the same bug?

Comment 8

18 years ago
Filed bug 70756 for the problem I observed.

Comment 9

17 years ago
As far as I can tell, this now WFM using 2001050404 on Win2k. Val, is this
working for you as well?
(Reporter)

Comment 10

17 years ago
Yes thanks, Oliver - confirming WFM too (Win98).

Comment 11

17 years ago
Marking so.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 12

17 years ago
verified on build 2001-08-14-trunk
Status: RESOLVED → VERIFIED

Comment 13

16 years ago
This testcase wfm, but see also bug 103055, "onmouseout event fired 
incorrectly, moving mouse over text counted as onmouseout".
You need to log in before you can comment on or make changes to this bug.