Live title selection doesn't work inside Library

VERIFIED FIXED in Firefox 3.6a1

Status

()

Firefox
Theme
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: whimboo, Assigned: mstange)

Tracking

({regression, verified1.9.1})

3.5 Branch
Firefox 3.6a1
All
Mac OS X
regression, verified1.9.1
Points:
---
Bug Flags:
blocking-firefox3.5 -
wanted-firefox3.5 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090523 Shiretoko/3.5pre ID:20090523033340

The name of live bookmarks cannot be edited anymore in the library and within the bookmarks properties (not on OS X). It works fine in the star panel. This is a regression on the 1.9.1 branch and was working before.

On OS X you will only see a static text in the library see the attached screenshot. On Windows it is a normal textbox in the liberary and the bookmarks properties dialog.

Worth for blocking? I'll check for a regression range.
Flags: blocking-firefox3.5?
I forgot the steps:

1. Open https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&product=Firefox&component=Search&bug_status=UNCONFIRMED&chfieldto=Now&known_name=Search+Unconf&query_based_on=Search+Unconf
2. Save this query and give it the name "Search"
3. Open this saved query and press Ctrl/Cmd+D to bookmark this page
4. Select the "Search (xx)" live title by opening the dropdown
5. Open library and check the bookmark name
6. Open sidebar and check the bookmark name

With step 5 and 6 you will see that you cannot choose the live title while staying in the library or the bookmarks sidebar.
No idea if this bug has to be split up. On OS X there is a regression which has been caused by the patch on bug 469631. On Windows it hasn't been working at all. I checked back to pre-alpha 1 releases.
Blocks: 469631
Keywords: regressionwindow-wanted
hm, wfm
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1pre) Gecko/20090524 Shiretoko/3.5pre
i have the dropdown there and i can open it...
After talking with Marco on IRC I played around with the network settings of my XP VM and got it to work. So some network issues fooled me yesterday.

So the only problem which still persists is the bookmark name field inside the library on OS X. The background of the textbox is grayed and no dropdown appears even after minutes. Markus, could this be a widget issue?

Screencast is available here: http://screencast.com/t/RY1FfOBRob
OS: All → Mac OS X
Summary: Name of Live Bookmarks cannot be edited inside Library or Bookmarks properties → Name of Live Bookmarks cannot be edited inside Library
Summary: Name of Live Bookmarks cannot be edited inside Library → Live Bookmark selection doesn't work inside Library
the microsummary is definately loaded since the textbox changes, but the dropdown does appear wrong, so this is probably a widget or style issue on OS X.
s/bookmark/title/ - Live Bookmarks are RSS feeds, Live Titles are microsummaries.
Summary: Live Bookmark selection doesn't work inside Library → Live title selection doesn't work inside Library
Also, this doesn't block.
Flags: wanted-firefox3.5+
Flags: blocking-firefox3.6?
Flags: blocking-firefox3.5?
Flags: blocking-firefox3.5-
Talked more with Dietrich about it. This is a sucks-doesn't-block thing, IMO, but we'd take a patch. I hope the fix is pretty simple.
Flags: wanted1.9.1.x?
Keywords: relnote
Steven, do you think this could be a widget issue?
(Assignee)

Comment 11

9 years ago
(In reply to comment #1)
> 2. Save this query and give it the name "Search"

What does "Save this query" mean? Which buttons do I have to press?
Look at the bottom of the page. It's called remember search. I'll try to find a better example.
(Assignee)

Comment 14

9 years ago
Thanks, I can reproduce it now. But the bug is different than you described: you can still edit the name, the field just doesn't look like you can. We just need to fix the styling in order to make it look like a proper textbox.
This is a pure CSS issue.
There is no drop down at the end where you can select the live or static title. It's not enough to editing the content.
(Assignee)

Comment 16

9 years ago
Oh, right.
(Assignee)

Comment 17

9 years ago
Created attachment 379737 [details] [diff] [review]
fix v1: remove custom style overrides

This patch just removes the custom styling that was applied to menulists in the library. I don't think the rounded button style fits in that context.
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Attachment #379737 - Flags: review?(dao)
Can you provide me with a screenshot for the droppable and another one for the non-droppable case, please?
(Assignee)

Comment 19

9 years ago
Created attachment 379744 [details]
screenshots

Updated

9 years ago
Attachment #379737 - Flags: review?(dao) → review+
Do we know what regressed it?
Comment on attachment 379737 [details] [diff] [review]
fix v1: remove custom style overrides

a191=beltzner, please land on trunk first and make sure it goes green before moving to mozilla-central
Attachment #379737 - Flags: approval1.9.1+
(Assignee)

Comment 22

9 years ago
(In reply to comment #20)
> Do we know what regressed it?

Bug 469631 regressed part of it (it removed the background color and the border), but the dropmarker was already broken before that bug. Henrik, can you find out more?
Keywords: checkin-needed
The marker was not visible but you were able to click on it to select the static or live title. Right now I don't have time to do more regressions testing on this bug.
http://hg.mozilla.org/mozilla-central/rev/125703fbe98d
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.6a1
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/e19084520fae
Keywords: checkin-needed, relnote → fixed1.9.1
Verified fixed on trunk and 1.9.1 with:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090527 Minefield/3.6a1pre ID:20090527031500

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090527 Shiretoko/3.5pre ID:20090527031214

Markus, why do the editable dropdowns have a different height as the normal text fields? When you have long queries the drop down will appear more then 5s later and shrinks about 2px in height. Shall I file a new bug on that so we can make it higher for all instances?
Status: RESOLVED → VERIFIED
Component: Bookmarks & History → Theme
Keywords: fixed1.9.1 → verified1.9.1
QA Contact: bookmarks → theme
wanted1.9.1.x cannot be removed. Seems like this has to be done by a driver.
Flags: blocking-firefox3.6?
(Assignee)

Comment 28

9 years ago
(In reply to comment #26)
> Shall I file a new bug on that so we can
> make it higher for all instances?

Yes, please.
Flags: wanted1.9.1.x?
You need to log in before you can comment on or make changes to this bug.