IPv4 addresses preferred over IPv6 ones

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
major
RESOLVED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: Aki Tuomi, Unassigned)

Tracking

3.0 Branch
x86_64
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; fi; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; fi; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

Opening the website mentioned in URL field, causes the IPv4 version to open. Only addresses with IPv6 only address are opened using IPv6. 

Reproducible: Always

Steps to Reproduce:
1. Have machine with IPv6 and IPv4. IPv6 must be under different interface
2. Disable proxy etc.
3. Open site with IPv4 and IPv6 address in DNS

Actual Results:  
Web site is opened using IPv4

Expected Results:  
Web site should be opened with IPv6

I have no IPv4 only settings, cache/proxy disabled. Operating system has IPv6 address on Teredo tunnel.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0 Branch
(Reporter)

Comment 1

9 years ago
It seems your handy webform did not in fact send the URL field, so two URLs that are failing visibly:

www.kame.net
www.sixxs.net

Comment 2

8 years ago
I cannot find anything wrong in this behavior. Windows prefers IPv4 over Teredo. Use "netsh int ipv6 show pref" to see how address selection is configured on your machine.
This is a mass search for Firefox General bugs filed against version 3.0 that are UNCO and have not been changed for 200 days.

Reporter, please update to Firefox 3.6.10 or alter. Firefox 3.0 is no longer supported and is no longer receiving updates. After you update, please create a fresh profile, http://support.mozilla.com/kb/managing+profiles, and test to see if your bug still exists. If you still the bug, then please post a comment with the version you tested against, and the problem. If the issue is no longer there, please set the RESOLUTION to  RESOLVED, WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.