IMAP does not close connection when Mail window closes.

VERIFIED INVALID

Status

MailNews Core
Networking: IMAP
P3
normal
VERIFIED INVALID
17 years ago
a year ago

People

(Reporter: benc, Assigned: Scott MacGregor)

Tracking

Trunk
Future
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Seamonkey PR2 on Win 98.

STEPS:
1- Open IMAP mailbox in NS6, and delete a message (I use "mark as deleted" in my 
prefs).
2- Open IMAP mailbox in NS4 or other IMAP client.

NOTE: Message flagged as deleted is not flagged as deleted.

3- Close Messenger in NS6 (but leave app running w/ a non-messenger window 
open).
4- Refresh view in NS4.

NOTE: Deleted message does not appear as deleted in NS4 (even though it is).

5- Quit NS6.
6- Refresh view in NS4.

NOTE: The deleted message is finally marked as deleted.

REQUESTED ACTION:

I think that if you close all mail related windows, you have essentially "left" 
mail. Although it might not be necessary to sign out or disconnect, you should 
at least update the IMAP server with your mailbox changes.
(Assignee)

Comment 1

17 years ago
All information is pushed back to the imap server as soon as we make the change.
The imap server makes no guaruntees that it will immediately push the change to
other open connections immediately. It's just a timing thing.

there is no such notion of "flushing our current imap state out when we log out
or close the last mail window". You don't queue up changes with the imap
protocol. Your message already was deleted and the server was informed.

the time lag between when it shows up on another account is also exacerbated by
the fact that you are probably running both the 4.x account and the NS6 account
from the same machine. so you have two connections to your inbox.

Marking invalid.

On a side note we do have a bug where all imap connections should be shut down
when we exit the last mail window but this was futured and it wouldn't really
solve your problem. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Target Milestone: --- → Future

Comment 2

17 years ago
Change QA contact to me for verify.
QA Contact: lchiang → huang
(Reporter)

Comment 3

17 years ago
For the amount of time I have used NS6 to read mail this has been consistent, 
and I find it too coincidental that the mailbox always updates after I quit.

So I'm going to run a packet trace to see what is going on, and I'll post my 
results here. (This is blocked until I buy a new hub, which might be a couple 
days).

Comment 4

17 years ago
we do close connections when the whole app shuts down, which flushes changes to
the server, just not when the the last mail window closes.

Comment 5

17 years ago
Yes. I did tried on two clients on 4.x and it is the same behavior as David &
Scott described above.
I am Making as verified based on David/Scott comments and my verification.
Status: RESOLVED → VERIFIED

Comment 6

17 years ago
I am still thinking this bug probably will be future but shouldn't be "Invalid". 
Even I check on 4.x with the same behavior, but I am wondering to know any 
possibility on Netscape6.0....Since Ben is going to run a packet trace to see 
what is going on and post his results here, I will let him reopen this bug once 
he has more input for this bug, I am start thinking this bug shouldn't be an 
"Invalid" bug......
Product: MailNews → Core
Product: Core → MailNews Core

Updated

a year ago
Duplicate of this bug: 608469

Updated

a year ago
See Also: → bug 490170
You need to log in before you can comment on or make changes to this bug.