Unexpected behaviors of the Search Bar...

VERIFIED DUPLICATE of bug 395750

Status

()

Firefox
Search
--
minor
VERIFIED DUPLICATE of bug 395750
9 years ago
9 years ago

People

(Reporter: Cor'e, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)

Changing the browser.search.openintab config to True does not work as expected.

I would expect that searches would open in new tabs.  

Another default behavior i would expect is that focus moves to the new tab after typing in a search at the search bar, this does not happen, i do not (yet) know the config to change this, but i would think it'd be the default behavior.

Yet another behavior i would expect of a Search would be that a new blank tab which has focus at the time of a search be utilized for the search, this appears to already be filed as Bug 344381 or Bug 320989 (?).

Reproducible: Always

Steps to Reproduce:
1.open about:config
2.set browser.search.openintab to TRUE
3.type a search in the Search Bar
Actual Results:  
If the typed query ends in an Enter keystroke:
- a new tab *is* opened.
- focus *remains* at the last focused tab.
- last focused web page is *not* moved into tab history.

If the typed query ends in a click on the Search icon (magnifying glass):
- a new tab is *not* opened.
- focus *remains* at the last focused tab.
- last focused web page *is* moved into tab history.

If the typed query ends in an Alt-Enter keystroke:
- a new tab is *not* opened.
- focus *remains* at the last focused tab.
- last focused web page *is* moved into tab history.


Expected Results:  
A new tab does not open when i type in a search into the search bar and click on the search magnifying glass icon or press Alt-Enter; however, it does open a new tab when i press Enter.  

Ctrl-k does not seem to change these behaviors.  (I cannot confirm the behaviors of middle-button on mouse as i do not have one).  Using User.js does not seem to change these behaviors.

WinXP Pro x32 SP3, FF 3010.  Rumors are that this also happens on *nix builds.

Annoyance, work-around is to press Enter after typing searches in Search Bar.
(Reporter)

Comment 1

9 years ago
I see a reason to not move focus to the new search results tab, that being if i initiate the search from a webpage i'm currently continuing to view, then i would want to background  my searches.  

But i'd like to see a config variable to toggle this, separate from the global open-tabs-in-background option.  (I guess i just mixed a Bug and a NFR, sorry for doing that).
To focus the new tab with the search results, change browser.tabs.loadBookmarksInBackground to false. It controls bookmarks, history (even locationbar) and search. If this sounds illogical to you, I believe there is also a bug for this. For example Bug 349615, but there should be more bugs with different solutions, more prefs or less prefs. 

Duping to bug 395750.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 3.0 Branch
Duplicate of bug: 395750
(In reply to comment #2)

> (even locationbar) 

I meant: locationbar history (the history in the dropdown).

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.